Forums

Software & Operating Systems

Software & Operating Systems
Microsoft, Linux, Productivity software, discussion

Dell Photostage Odd issue

This question is not answered

Hi,

I'm wondering if anyone can help resolve the following issue.

Windows 7 - Dell Photostage. Earlier today received a message saying something along the lines of 'You need to update this application' when trying to open the Photo element.Clicked to update, but this was whilst currently installing MS Office 2010.

During the install, the install shield for Photostage then stopped saying 'There is another install in progress. Please wait until this is finished before....'

It gave me Retry and Cancel options. I chose Cancel, thinking this would revert to pre-updated so I would simply need to update again. Instead, it appears to have uninstalled the Photostage product, and now when I click the Photo link, I get 'This application is not installed. Click here to download.'

The click here link takes me to the Arcsoft homepage. I have also tried to do a repair and modify through Control Panel, but get an 'unable to locate PhotoStage.msi' issue. A manual search of windows doesn't find this file.

Any ideas how to get this back, as I cannot find it on the Arcsoft site, cannot use Repair?

Thanks

Stu

All Replies
  • Should also add that all other elements of Stage work fine.

  • I had the exact same problem happen. Did you ever find a resolution to this?

  • Hi, I did, but it took a bit of work.

    I logged the issue with Dell email support. Initially, they came back to say that they couldn't solve this by email and I should call the chargeable support line.

    I polietely replied to say I wasn't going to pay for them to fix an issue caused by the DellStage install sheild! Fortunately, they then called me to discuss my reply, and put me through to another tech team. I explained that I simply needed the PhotoStage.msi and I could do the install myself.

    Although they wouldn't allow this, they did then remote log onto my machine and verify the issue I was having. That done, they did a remote uninstall of all the DellStage products, then transferred down a new install zip, and then installed it.

    Having looked into this further prior to them resolving the issue, I did notice that all the DellStage .msi files reside in the Installer directory on Windows, except PhotoStage. I don't know why that would be the exception. Although there is an installer package for PhotoStage, it's the only one that can't re-install as it looks for an invalid path to the .msi file.

    If you have the same issue, then register with dell online and email their support team. If it helps, you can quote my support ticket :

    Inspiron#GEN##RETC0 (KMM37877682I57L0KM)

    All the best

    S

  • Same exact issue here. Thank you for posting your experience and how you resolved it!

  • Wow... after over 30 minutes on the phone with a Dell tech rep and his GoToAssist connection not linking to me, he finally just sent me a link to download the Dell Photo Stage .msi file (not really his fault, he was a good rep, but Dell's system plain sucks sometimes). I downloaded the msi and installed it in less than 1 minute and the problem was solved.

    When I started the call I said all I needed was the Dell Photo Stage msi install file and I could handle it myself, which would have saved everyone time and money, but no... we have to act like everyone who owns a computer is stupid and play this game with support while they try to connect and check things that are already correct. Then, their "system" or "tools" as they call it, sometimes are "down" (as I've been told many times in the 12+ years of owning Dell systems) and it's just a big waste of time.

    At one point the tech told me to log into my Dell account and use the service tag to grab the Applications. I said to him "already been there, and the Dell Stage software is not listed in the applications to download for this brand new system, otherwise I wouldn't have needed to call you!".

    I wasn't rude about it - no reason to be - he was just doing his job. But still, it's absolutely ridiculous that we have to play "twenty questions" and let someone into our systems (if they an get their gotoassist working on their end) to solve a very simple issue, when all he had to do in the first place was give me the link to the file so that I could download and re-install Photo Stage. Could have been a 2 minute call and done.

    I wouldn't even have bothered if it were my own system, because "Dell Stage" is just unnecessary Bloatware, but the system is for a family member who wanted to have "what her new computer came with". If it was my own system I would just completely un-install Stage entirely.

    So as per usual - big waste of time for me and waste of money for Dell to have a tech sit on the phone trying everything the hard way first instead of just giving us a direct link to the file so we can re-install it ourselves.

    Sigh...

  • I had the same problem with photo stage and think I might have figured it out.  When I use my wireless mouse it gives me that same error shuting down message everyones getting. BUT when I dont use the wireless mouse  and just the touch pad it doesnt give me that message.  It seems like a dumb solution when my wireless mouse works for everything else but has anyone else tried that?

  • I have to same issue and it works fine when I unplug my wireless mouse and use the touch pad. Weird!

    Be interesting to see how long it take them to fix it.

  • I had the exact same thing happen to me a few minutes ago.....

  • This thread is a year old and the issue is still happening to users. Seeing a trend here...