ST2420L and ST2420

Peripherals

Peripherals
Dell Monitors, Printers, Projectors, Hardware and Software discussion

ST2420L and ST2420

This question is not answered

I recently purchased a new XPS 9100n with ATI 5770 video card. The package came with an ST2420 and I purchased an additional ST2420L because of the deal they had.

I have made the 2420L the main monitor and it is hooked up via HDMI. The 2420 is an extended display via the monitors VGA connect with a DVI-D adapter.

My question is, why does the 2420 use the entire monitor space, yet the 2420L gives me a one inch border around it of dead space? I have no option to adjust the size? I have all of the correct drivers and maximum resolutions set.

The only info I can find is in the product info that states the following.

The monitor will not fill the entire screen. The picture does not fill the height or width of the screen.
  • Due to the non-standard formats of DVDs, the monitor may not show the full screen pictures.

The kicker of course being, I am not viewing any DVD. Just windows. When I put the monitor into self test mode, all of the visible monitor is lit and performs correctly, but when I hook the monitor back up, I get the border.

Ideas please?


Rich

 

All Replies
  • The Ati Catalyst scaling default is set to around 7.5 under scan which causes wide screen displays to show thick black borders around all 4 sides of the display.
    * Right click on the Desktop
    * Open Catalyst Control Center
    * Switch to Advanced mode
    * Click the Dropdown Menu Graphics in the top Right
    * Select Desktops and Displays
    * Right click on the 2420L. This part is very crucial. There is a little picture of a tiny Monitor and tiny Arrow at the far bottom left of the CCC menu. It is this tiny Arrow that you left click on by the button that says Basic and the button that says OK. When you click on the little black arrow (not the Big Black Arrow in the middle of the CCC window, you will get the option to click Configure. Then the following 6 buttons will be available to you:
    Attributes
    Avivo Color
    Scaling Options
    HDTV Support
    LCD Overdrive
    Pixel Format
    * Under Attributes, check the Enable GPU scaling box and the Scale image to full panel size
    * Click Apply
    * Select Configure
    * Click on the Scaling Options tab
    * Move the scale to the right until you get a full screen image 0%
    * Click OK

    (Liaison for Desktops, Alienware, Monitors)
    Quick link for Manuals and Drivers

  • Quick easy and painless.

    100% the right fix.

    thanks Chris.

     

    Rich

  • I had the exact same issue with that monitor/video card combo.  And the same success following this advice.  Thanks!

  • Same issue for me. These instructions worked like a charm. Thank you!

  • This is exactly my problem, but when I enter the Catalyst Control Center and go to Desktops and Displays, there's no display to select.  Clicking on "Detect Displays" does nothing.

    Any ideas?

  • I tryed what you said all the way until right click on the 2420L, I could not figure out what you were talking about, therefore I just click on the OK button to get out and now my screen is completly black, i had to hook up the analog hook to be able to use the computer.  Can you help me!

  • HectorRuiz, it's been about 9 months since I solved my problem, so I can't give you all the details from memory.  But the thrust of it is that it was a driver/CCC issue.  I had to remove the current driver and Catalyst Control Center with a driver-removal tool I found online.  (It's not as easy as it sounds; there's lots of junk you have to remove manually in safe mode.)  But once I installed the new driver/CCC with all of the old version finally removed, I was able to adjust the scaling to eliminate the black borders.  Don't ask me why Dell ships the HD system when it's not set up properly for HD.

    Good luck.

  • Chris,

    I developed this problem when I switched to HDMI.  I googled the problem and your solution worked like a charm.  Thanks!

    David

  • Thanks, Chris.  I had the same problem.  I suspect your solution is for a version of Windows other than Windows & (my operating system) but your instructions were close enough that my problem is now solved!