Forums

Peripherals

Peripherals
Dell Monitors, Printers, Projectors, Hardware and Software discussion

Dell Printer Home says "no compatible printers are installed" but I have a working Dell v313w

This question is not answered

I just replaced my Vista laptop with a new Win 8 laptop.  I installed the Dell drivers and firmware.  The printer was working okay but needs the head-alignment services of Dell Printer Home (DPH).  I'm doing this without a USB cable.

But DPH gives the complaint listed in the subject, and does not launch.  How do I get a working Dell Printer Home on Windows 8???

All Replies
  • Hi Kayogo,

    You may need to install the Dell V313W printer software from www.support.dell,com for  Windows 8 on your computer. Please do not forget to choose the correct  drivers for either the 32-bit or 64-bit Windows 8 version you are using.

    You may also click on the link below to access the Dell Support Website. Once on the website, enter your service tag and then download and install the relevant drivers.

    http://dell.to/QjjZDA

    Hope this resolves the issue for you.

    Please let me know if you have any further queries.

    Thanks and regards, 
     Prateek_K
     
    #iworkfordell

  • I did that first.  I downloaded DELL_V313w_wcr_32_en and installed it, which gave me the Dell Printer Home that does not work.

    I downloaded Dell_V310-V510_Series_B082511_00_FWUpdate and ran it.

    Just now, I downloaded R318939 and ran it, but it cannot find my printer.  Even if I give it the IP number, it says no printer was found at that address.

    So: nothing is working yet

  • Hi Kayogo,

    Thank you for your reply.

    Please let me know if you are attempting to install the Dell V313W printer wirelessly. In case you are, I would request you to first install the printer using a USB cable and once the connection between the printer and the computer is established, then attempt to install the same wirelessly.

    Also, please check your firewall settings. It could be possible that the anti-virus program on your computer is not able to identify your printer correctly and is blocking the printer from communicating with your computer.

    Please let me know if the above steps are helpful or in case you need any further assistance.

    Awaiting your reply.

    Thanks and regards,
     Prateek_K
     #iworkfordell

  • The Dell printer was already installed wirelessly.  But your idea was right.  As soon as the USB cable was plugged in, Dell Printer Home could recognize it.  Moreover, it turns out that the scanner function worked only with the cable, not wirelessly. 

    When fully re-'installed, there are two printer icons in the control panel, one representing wireless operation, that seems to print only and has a generic icon.  The other has an icon that looks like this printer, and greyed-out unless the USB cable is in place.
    I liked it better in Win 7, but it's workable.
    Thanks.
  • Hi Kayogo,

    Thank you for your reply.

    You may need to uninstall the printer software and your anti-virus program completely from your computer and then attempt to reinstall the printer again. After you have installed the printer software, please re-install your anti-virus program.

    Hopefully it should work as normal once you do so. 

    Thanks & Regards
    Prateek K
    #iworkfordell

    For easy access to drivers, manuals and product updates, please visit our Support Site .

  • I had this sort of working for a while, but yesterday the printer stopped working at all with my Win 8 laptop.  The driver was still there, but all attempts to print would eventually fail with the message that communication with the printer is unavailable.

    It happens that we have a Win7 laptop and a Windows Vista laptop.  We tried all of them, and it's only the Win 8 machine that fails.

    I am using a USB cable to connect to the printer.  I know that wireless is working on the computer because there's no ethernet cable and I'm able to post this.

    I have removed the printer from the control panel.  I have been unable to remove the Dell Printer Home because I cannot find any place to do that -- it's not in the list of installed software, and the tile in "all apps" that says to remove the printer does not do anything.

    Attempts to reinstall drivers no longer ask if I want to use USB or wireless, and seem to be missing steps.  I'm guessing this is because it cannot talk to the printer.

    This is our only scanner, and I really miss that capability.

    I have not removed anti-virus because I have no media to reinstall it, and I'm not sure how I would get it back.  It's a Norton thing that came with the computer, a Toshiba.

  • kayogo,

     

    Please continue with , my weekend to work and Prateek may have a quicker response.

     

    On the Windows 8 machine...

     

    First run Delete Print Jobs to remove any stuck print jobs from the queue. A stuck print jobs may be the problem. After you restart, try and see if it functions. If not, run delete print jobs, again, restart.

     

    Make sure the printer is not usb cab;l connected to this computer.

     

    Hit the Windows key and the x keys at the same time, programs and features, Dell V313w Printer, uninstall.

     

    Restart your computer

     

    Make sure the printer was removed. Manual Printer Driver Removal

     

    With the computer online, insert the printer disk, choose aditional computer and select the proper selection, then follow the instructions.

     

    Try reading...

    Allow a printer past Norton

     

    If you need further assistance, please reply back and will ba able to assist you.

     

    Is there a reason the printer is not usign the wireless adapter? A desktop computer that is plugged in to a wireless router can print to a wireless printer with no usb cables attached.

     

    Rick

     

    #DellRockStar

    What is a Dell Service Tag and how do I locate it? 

     

     

    Original poster, If you have solved your problem, can you please mark the correct thread(s) with your solution. Thanks 

    Welcome to Dell Community!

  • I tried as much as I could of these instructions.  In order, here's a report

    1) I composed and ran the DeletePrinterJobs.cmd file.  Neat.

    2) Unplugged the USB cable

    3) As near as I could tell, the V310 was already uninstalled.  This makes sense, kind of, because the previous thing I had tried was to uninstall then reinstall, but the latter part failed.

    4) Restart

    5) Check that there's still no V310 printer installed

    6) I have no printer disk.  I've been installing from the file downloaded from support.dell.com: DELL_V310w_wcr_32_en.  This is the same file that worked on the other laptops.

    a) with the USB cable still unplugged, the printer was not seen

    b) with the USB cable plugged in, I wait forever for the Continue button to un-grey.  I'm using the USB cable that worked with the other laptops, on a port that works okay with a USB stick.

    7) The like to allow a printer past Norton seems to be written for an older Symantec product.  It is impossible to follow those instruction on what I'm using: Norton Internet Security.  In any event, the installation went okay when I first got the computer, and I haven't changed Norton settings recently.

    8) To answer the question: the printer was not using the wireless adapter because of an earlier instruction to attempt installation via USB first.  That failed, and that's how I left it when I replied back.  I'd be happy to use wireless, but I cannot get it, or anything much else, working right now on this printer with Win 8.

    I look forward to hearing from DELL-Prateek K.

  • kayogo,

     

    Make and model of your wireless router and the type of security you're using? What channel?

    I use these Recommended Wireless Router Settings I use channel 11. I would make a new SSID to make connecting easier.

     

    On the Toshiba laptop, did you install Windows 8 or did Windows 8 come installed on the system? If you installed it, did you install the chipset drivers reight after installing Windows?

     

    Running Delete Print Jobs, removes stuck print job(s) from the queue. A stuck print job, you can uninstall and reinstall the printer and the problem comes back. I recommend using programs and features to remove the printer and Manual Printer Driver Removal

     

    That gives you a clean start with installing the printer.

     

    With the computer online, install the printer drivers, choose new installation, network and follow the instructions. It will ask for your network and password. When your done, the printer should work wirelessly.

     

    To scan/fax, you'll need an OCR program installed. If you CLICK HERE, on the next page, start conversation with, we can discuss OCR Program options there.

     

    The instructions for Nortons firewall may be for an older version but should get you in the area of the firewall so you can allow the printer past the firewall.

     

    If the Windows 8 drivers do not work, try the Vista drivers in the Vista Compatibility mode Drivers can be found at Dell V313 All-In-One Printer owners thread

     

     

    Rick

    #DellRockStar

    What is a Dell Service Tag and how do I locate it? 

     

     

    Original poster, If you have solved your problem, can you please mark the correct thread(s) with your solution. Thanks 

    Welcome to Dell Community!

  • Following the Manual Printer Driver Removal instructions, there is no icon for the Dell printer, just Fax, Windows XPS, and our other printer (an HP).

    BTW, printing to the HP is working.  Wirelessly to the router and via ethernet to the printer.

    Synopsis: connecting via USB finally works, but functionality is limited to printing (not scanning) and I cannot add wireless connection.

    Installing DELLV510_wcr_32_en (from the DELL web site), using "Run as Administrator"

    I'm given the choice of "New Printer" or "Additional Computer", I choose "Additional Computer".

    It goes through "Transferring Software"

    It asks about "Connection Type" with choice of wireless or USB.  

    - if I choose USB, it seems I can get the printer recognized if I switch USB ports enough times.

      NOTE: This is the step where I was stuck before.  Fooling with USB ports seems to make a difference, even if I wind up at the same port that did not work at first.  The rest goes smoothly except that it promises but does not deliver a sample page.

    It announces it sees the V313, and brings up a window that talks about a sample page, but there does not appear to be a link or button to print one, just a checkbox labelled "see great printing results", which I check, and a Continue button, which I click.

    I choose not to register (did that long ago), nor the experience improvement program. Continue

    I decline firmware update (did that already). Continue.

    It thanks me. Continue.

    My browser is taken to a Dell site for printer supplies.

    Dell v310-V510 is now in the control panel, and is the default printer.  I can print this message that I'm working on.

    Intending wireless operation, I run the driver installation again (run as administrator)

    I can "install a printer" or "update/repair software", I choose "install a printer".   This choice did not appear the first time.

    I again choose "additional printer"

    I again opt out of firmware updates

    It says its done.  I did not get to choose wireless over USB.  There is no additional icon in the control panel.

    I run the driver a third time.  This time I choose to "update/repair software"

    I still do not get to choose wireless over USB.

    At least the printer is operational again, but I thought I should be able to add wireless capability.  Should I remove the driver again and try it wireless only?  I'm only attempting USB installation because an earlier message from you (DELL) said to do that first.

    One more thing.  Dell printer home seems non-functional. Its buttons and

    links don't seem to do anything. I've tried "print test page" and "PDF" to

    no avail.

    So things are still not quite right.  I can print pages, but that's about

    it.  I really need the scanner.

  • kayogo,

     

    HP Printer is working wirelessly, good sign.

     

    I would run delete print jobs and also make sure the Dell V313w Printer is uninstalled, then restart the computer.

     

    With the computer online, try the Vista drivers in the Vista Compatibility mode Drivers can be found at Dell V313 All-In-One Printer owners thread

    Choose new installation, network and follow the instructions. It should ask for your network and password. If it doesn't take your network or password, then tell it your neighbors network and fake a password, it will fail. Then try your network and password and it should install. Once the printer is setup for wireless, you should be able to print.

     

    To scan, you need the OCR Program installed from the printer disk. As for scanning, if you have the disk that came with the printer, then insert the Printer disk and stop it from running. Go to My Computer and double click on it. Look for the drive with the Dell disk in it. Right click on it, left click explore. Look for the OCR Folder. In the OCR Folder, there is an Abbyy Folder. right click on setup.exe, that's in the Abbyy Folder and left click run as administrator. This will install the OCR program.

     

    Then try reading...

    Update list of applications to send scans to

     

     

     

    Rick

     

     

    #DellRockStar

    What is a Dell Service Tag and how do I locate it? 

     

     

    Original poster, If you have solved your problem, can you please mark the correct thread(s) with your solution. Thanks 

    Welcome to Dell Community!

  • You directed me to Dell V313 All-In-One Printer owners thread, which seems sensible, but the 32-bit driver that it directed me to (R246253) failed miserably, even trying the "recommended compatibility settings) which seemed to be  for Win XP SP 3.  The 64-bit driver did not even get to suggesting a compatibility mode.

    In any event, the drivers did not load.  I was better off with the ones I've been using, which I'll now have to hope will re-install.

    I do not want OCR.  I just want to scan photos and make PDFs.  This does not seem to require OCR.  I've found OCR is still not really ready for prime time and is not helpful for me.

  • kayogo,

     

    Dell does not have a V310 printer. What exact model of printer do you have?

     

     

    Rick

    #DellRockStar

    What is a Dell Service Tag and how do I locate it? 

     

     

    Original poster, If you have solved your problem, can you please mark the correct thread(s) with your solution. Thanks 

    Welcome to Dell Community!

  • it's a v313w according to the front panel.

  • messages are asking me to mark this thread solved if it is.  but it isn't.  and now it appears someone else is having a similar problem.