Configure 5324 Switch to connect (via trunk) to Virtual Switch (vSwitch) with VLAN Tagging (VST) on ESX/ESXi host

Network Switches

Network Switches
Information and ideas on Dell PowerConnect network switch solutions.

Configure 5324 Switch to connect (via trunk) to Virtual Switch (vSwitch) with VLAN Tagging (VST) on ESX/ESXi host

This question has suggested answer(s)

I'm trying to connect a Dell Powerconnect 5324 to a ESXi virtual switch running on an Intel Modular Blade Server.  I'm having problems with the trunk between the 5324 and the vswitch.  I am able to get to the ESX itself on the management network...but not able to talk to the virtual machines on the other side of the trunk (i.e., on the vswitch).  

Does the 5324 have dot1q enabled by default? 

Below are the instructions from VMware:

To configure Virtual Switch (vSwitch) VLAN Tagging (VST) on ESX/ESXi host:

  1. Assign a VLAN to a portgroup(s). Supported VLAN range (1-4094).
  2. Set the switch NIC teaming policy to Route based on originating virtual port ID, this is set by default.
To configure the physical switch settings:
  1. Define ESX/ESXi VLANs on the physical switch.
  2. Allow proper range to ESX/ESXi host.
  3. Set the physical port connection between ESX/ESXi and physical switch to TRUNK mode. ESX only supports IEEE 802.1Q (dot1q) trunking.
    • Physical switch is set to TRUNK mode
    • dot1q encapsulation is enabled
    • Spanning-tree is set to portfast trunk (for example, Port forwarding, skips other modes)
    • Define VLAN interface
    • Assign IP Range to VLAN interface
    • VLAN Routing – and VLAN Isolation

      Caution: Native VLAN ID on ESX/ESXi VST Mode is not supported. Do not assign a VLAN to a port group that is same as the native VLAN ID of the physical switch. Native VLAN packets are not tagged with VLAN ID on the out going traffic toward ESX/ESXi host. Therefore, if ESX/ESXi is set VST mode, it drops the packets that are lacking a VLAN tag.
This sample is a supported Cisco Trunk Port configuration:
interface GigabitEthernet1/2
switchport                                        (Set to layer 2 switching)
switchport trunk encapsulation dot1q  (ESX/ESXi only supports dot1q, not ISL)
switchport trunk allowed vlan 10-100   (Allowed VLAN to ESX/ESXi . Ensure ESX/ESXi VLANs are allowed)
switchport mode trunk                       (Set to Trunk Mode)
switchport nonegotiate                      (DTP is not supported)
no ip address
no cdp enable                                  (ESX 3.5 or higher supports CDP)
spanning-tree portfast trunk               (Allows the port to start forwarding packets immediately on linkup)
All Replies
  • I pulled this directly from the 53xx User Guide

    support.dell.com/.../5324UG.pdf

    Feature Specifications

    VLAN

    • VLAN support for Tagging and Port Based as per IEEE 802.1Q

    • Up to 4094 VLANs Supported

    • Reserved VLANs for internal system use

    • Dynamic VLANs with GVRP support

    • Protocol based VLANs

    Here is a sample config

    Console#config

    Console(config)# interface Ethernet xx

    console(config-if)# switchport mode trunk

    console(config-if)# switchport trunk allowed vlan add 10-100

    console(config-if)# spanning-tree portfast

    If this is not working you can try using a general port mode instead of trunk.  It is similar to the trunk.

    Hope this helps,

    Keep us updated if you can.

    Get Support on Twitter @DellCaresPro

    Download the Dell Quick Resource Locator app today to access PowerEdge support content on your mobile device! (iOS, Android, Windows)

  • I think I have the above in place already.  Here is my configuration:

    spanning-tree mode rstp

    interface range ethernet g(1-20)

    spanning-tree portfast

    exit

    interface port-channel 3

    spanning-tree guard root

    exit

    interface range ethernet g(1-20)

    spanning-tree guard root

    exit

    interface port-channel 3

    description LAG-to-Intel02SW01

    exit

    interface port-channel 3

    switchport mode trunk

    exit

    vlan database

    vlan 10,20,80,90,200

    exit

    interface range port-channel (1-3)

    switchport trunk allowed vlan add 10

    exit

    interface range port-channel (1-3)

    switchport trunk allowed vlan add 20

    exit

    interface range port-channel (1-3)

    switchport trunk allowed vlan add 80

    exit

    interface range port-channel (1-3)

    switchport trunk allowed vlan add 90

    exit

    interface range port-channel (1-3)

    switchport trunk allowed vlan add 200

    exit

    interface vlan 10

    name ProdNet01

    exit

    interface vlan 20

    name ProdNet02

    exit

    interface vlan 80

    name OfficeNet

    exit

    interface vlan 90

    name DMZNet

    exit

    interface vlan 200

    name BackupNet

    exit

    interface range ethernet g(1-4)

    channel-group 3 mode auto

    exit

    If so - then the problem must be on the ESX side.