Limited network connection on Dell Wireless 1704

Networking, Internet, Wireless

Networking, Internet, Wireless
From Wi-Fi to wired Ethernet, mobile broadband to modems: it's all spoken here.

Limited network connection on Dell Wireless 1704

This question has suggested answer(s)

I bought a new Dell Inspiron 14Z 5423 last week with windows 8 and I keep getting "Limited" on wireless connections after every few minutes.

I already try every Dell tutorial for maximize the wireless card connections, disabled Mcafee firewall and install and re-install any driver from my "product support" page and from this post and nothing seems to be working.

Is there any solution for this problem?

All Replies
  • Hi DavidCo90,

    The issue is with the incompatible settings of wireless card with the wireless network. Please follow the steps mentioned below.

    First of all uninstall the wireless card drivers from your system and update the latest wireless card drivers for your system from the support website : support.dell.com and reboot the computer.

    • Press 'Windows'+ 'X' key combination on keyboard.  
    • Click on Device Manager from the menu that pops up from the bottom left corner of the screen.
    • Expand Network Adapters, right click the wireless card and choose Properties

    Make the following changes

    • Change 802.11h+d to Strict 11h
    • Change Afterburner to Enabled
    • Change Antenna Diversity to Main
    • Change AP Compatibility Mode to Broader Compatibility
    • Change BSS Mode to 802.11g Mode
    • Change BT-AMP to Enabled
    • Change Fragmentation Threshold to 2300
    • Change Locally Administered MAC Address to 1234567890AB (This step is important)
    • Change Minimum Power Consumption to Disabled
    • Change PLCP Header to Long
    • Change Roam Tendency to Aggressive
    • Change Roaming Decision to Optimize Distance
    • Change RTS Threshold to 2300

    Click the Power Management tab

    • Uncheck Allow the computer to turn off this device to save power

    Also Open Power Options from the control panel -> Hardware and Sound

    • Click Change plan settings for the selected power profile
    • Click Change advanced power settings
    • Under Wireless Adapter Settings , click Power Saving Mode and change the settings to Maximum Performance
    Now delete all the wireless profiles from your computer and reboot the computer again and try to connect to the wireless network.
    Hope the above steps resolve the issue.
  • The problem is that when you do this: Change Locally Administered MAC Address to 1234567890AB

    It will disable SoftAP feature....