Networking, Internet, Wireless

Networking, Internet, Wireless
From Wi-Fi to wired Ethernet, mobile broadband to modems: it's all spoken here.


This question is not answered

i have a dell inspiron mini with a dell wireless 1397 wlan mini-card... yesterday, the F2 key for enabling-disabling wlan stopped working... n it was disabled when it stopped working so now no matter where i go to enable it (in the device manager, it says that it's enabled), the wireless network connection icon in the system tray has the red cross on it and doesn't show wireless networks in range (it says it cannot configure this wireless connection)... all the other function keys are working just fine

the other problem i've had from the start is that when it connects to my linksys WAG200G, it works for about 2-3 weeks and then stops working and turns the router light red so not even the pc (to which the router is connected) nor any other device can use the wireless (that's why i had to disable the wlan card in the first place)... n then after its been disabled for a few weeks, it works agen...

PLEASE HELP!!! i love my little baby dell :(

All Replies
  • Try a live cd to check if is a hardware problem or software.

    If is working must be a soft issue, if doesn't is a hardware issue.


  • I have run into this with my Dell Inspiron Mini as well. Exact same symptoms. It took me some time but i SOLVED it out..!

    Actually the F2 key (in some models Fn+F2) does not turn the wireless radio on and off by itself. Instead this key combination is there to bring up a tiny piece Dell Utility software called WSED.EXE which should have already been started up at the start up and running in the background.

    Under normal operation WSED.EXE is a Dell Utiliy Software which displays an icon in the tray when running and pops up a window when pressed to the F2 key (in some models Fn+F2) or when double clicked on it's icon at the tray. Once you have it's window opened up there you will see the check boxes to enable the wireless modem and the bluetooth. (provided they had been enabled at the BIOS settings Advanced>Wireless) Just put a check on the wireless modem and you are done. If it doesn't show your wireless modem then go to your BIOS at boot by presssing F2 and simply eneable the wireless modem. (BIOS settings Advanced>Wireless)

    Solution: In my case this WSED.EXE was not listed in the startup programs hence it was not running in the background at all. In my Windows 7 home edition this program is located at

    c:\program files\wsed\wsed.exe.

    When i run it manually it's icon (something pink) showed up in the tray and F2 key started working as explained above. I could turn the wireless raido on. Then in order to have that application to start automatically everytime i switch on the netbook i added it to the list of startup programs and everything returned back into normal as day one.

    I hope this solves your problem.