Forums

Mobile Devices

Mobile Devices
Mobile devices Hardware and Software discussion

Latitude 10-ST2 dock not recognized

This question is not answered

I ordered the docking station with my Latitude 10-ST2.  It just came today so I've been doing my recovery and backup tasks.  Once I had time to mess with the docking station, I found I couldn't use it.  When I attach the tablet to the dock, the tablet doesn't recognize any of the USB ports (front and back) on the docking station.  In Control Panel - Device Manager it shows "Other Devices - Unknown Devices" with a yellow exclamation point.  Also, when plugging it in, on the Windows desktop in the notification area, I get the error "The last USB device you connected to this computer malfunctioned, and Windows does not recognize it."

I haven't tried plugging in HDMI or Ethernet but I did test the audio port and it worked.  The tablet is also receiving power and charging while plugged in (a light on the dock).  I can't update the driver because it doesn't know what to update. 

How do I get my dock working?  The main reason I bought it was for the four USB ports.

Thanks,

Sandy

All Replies
  • It should work if the system drivers are installed. I reformatted my system today and my dock was recognized after i installed the Intel chipset drivers. Unfortunately now my webcam and wwan card do not work. Dell does not have the bugs worked out for sure.

  • I am having the same issue. Tried all the available driver updates but nothing worked. Contacted Dell,_ who sent  a replacement dock. The new dock was just the same. This looks like a driver issue but there is no specific driver available for the dock which was confirmed by Dell support. At this point not sure what  else to try except replace the whole system which is a pain. Did you find a solution?

     

    By the way also found that external Keyboard and mouse do not work when connected to the dock.

  • I received a replacement dock yesterday - it doesn't work either.  It has something to do with that port on the bottom of the tablet.  If I plug the power cord into the tablet, it charges the tablet.  If I plug the tablet into the exact same type of plug on the docking station, it charges the tablet but not much else.  I tested the other ports on the dock - the USB and Ethernet do not work.  The HDMI and audio work.  So, data transfer is out, but media works.  ??

    I can plug any USB device into the tablet when it's undocked, and the USB device is recognized.  But as soon as I plug the tablet into the dock (with USB still attached), the USB device disappears.  There's a micro-USB on the bottom  of the tablet next to the power port.  If I connect the tablet to a computer via the micro-USB, the tablet power icon says "Plugged in, not charging" but the desktop computer does not register a USB device has been connected.  I get the same "plugged in, not charging" if I plug the micro-USB in to the tablet and the other end straight in to a power source.  How can it be plugged in but not charging?  If I plug a power cord into the tablet, and a micro-USB cable to the computer (so it's getting power and data), the desktop computer still does not recognize a USB device has been added.  What's the point of the micro-USB if it won't transfer data and won't charge the tablet?

    It's either a driver issue (not recognizing those ports at the bottom of the tablet as data transfer ports) or there's a physical disconnect inside the tablet where the data capabilities were not wired up to the ports.  I guess it's possible that we've both received docks that weren't manufactured properly but that's a stretch.  You have two docks that won't work, I have two docks that won't work. 

    Dell tech support is supposed to contact me again to follow-up on the second dock.  I'm busy today or else I'd call them.  I'll try tomorrow.  If you find out anything, please let me know, and I'll do the same.

  • Flemo123,

    Here's the final status on my tablet.  A Dell tech tried updating some of my drivers with a set of files that I couldn't find on the Dell web site (something only they have access to or maybe something they just don't tell customers about?).  That didn't work.  She asked me to "Refresh" the computer (charms Settings | PC Settings | General | "Refresh your PC...".  (your docs are still there, but apps disappear except for apps from the Windows marketplace).  That didn't work.  She asked me to reinstall (directly below the Refresh option called "Remove everything and reinstall Windows".  Also known as a factory reset.  This can take a few hours so she said she'd call me back the next day.  She didn't.  I ended up calling Dell.  Anyway, after the reinstall, I ran Windows update until no more updates were available, but the dock was not recognized.  I still have the other dock they sent (the original) - the tablet doesn't recognize it either.  

    The Dell tech I spoke with today said they will be replacing my tablet.  Since the OS was reloaded (factory reset), updates were done, and drivers updated as much as possible, they say the problem is not with the OS install but with the hardware (tablet).  Also note, the micro-USB port on the bottom next to the power port does not work (re: my previous post).  Since all USB drivers are up to date, this seems to indicates a hardware issue.

    Hopefully, your problem can be fixed with a factory reset.

  • This must be an issue that is specifically to your tablet because I have this tablet and dock and mine works perfectly. Do you have the latest bios?

  • My BIOS is version A03, which is the latest version (2/1/2013) according to Dell.  Yes, it appears to be an issue with my tablet.

  • Let me tell you, Dell's technicians suck.... they don't know how to think for themselves, oh let's try a reboot....

  • Have you ever solved this docking station problem?  I have had this table since June 2013.  I have never been pleased with the docking station.  My wireless mouse and keyboard as well as my external hard drive work periodically, but definitely not consistently when plugged into the docking station.  The same goes with my printer.  I can plug any of these devices into my tablet when it's not docked and they will work, no problem, but when I plug my tablet into the dock, the usb ports aren't recognized.  So, I have to turn off the mouse, unplug the little wireless thing from the usb port and plug it back in and then it's usually recognized.  My external hard drive is recognized less often.  I have dealt extensively with dell tech support, they have done hardware diagnostic tests, updated all the drivers (numerous times), reconfigured my tablet to factory settings, and replaced my docking station.  New docking station has the same problem.  Nothing has worked.  All my usb devices work on other computers, just not on the docking station.  I'm very frustrated, I need a computer that works with more than one usb port.  The latest with dell tech support is that I am supposed to use  my computer over the weekend and see how it goes, hen we'll talk on Monday.  Hello!  The problem wasn't solved when we got off the phone today, why is it going to be any different?

    Any help would be great.  Where do I go from here?

  • I am having the same issues. I just upgraded to Windows 8.1 Pro. No USBs on the Docks work. USBs on the tablet only works when undocked ... Please Help!

     

  • I am having the same problem.  Did anyone figure this out and resolved this issue?