Dell Venue 8 Pro not charging?

Mobile Devices

Mobile Devices
Mobile devices Hardware and Software discussion

Dell Venue 8 Pro not charging?

This question has been answered by jfreiman

I purchased this from amazon and it came fully charged. I used it for roughly 3 days and I let it die last night watching a video. I left it charging 3 hrs today with the device off and when I powered it on the batter only says 2% charged. I am using the provided charger that came with the device and the light is on when it is charging

All Replies
  • Well it's at last charging! I have no idea what changed but having followed your suggestions which, unfortunately seemed not to work, I plugged in the charger into the DV8P, held the power button and then turned on the power to the charger. The charging light blinked for a couple of seconds and then went white and started to charge. Bizaar. Whatever did it, I've updated the BIOS etc and now hoping this little hiccup is now over! Thanks all for your suggestions.

  • Did you try this on a Venue 11 Pro or a Venue 8 Pro?  It does not seem to work on a Venue 8 Pro.

  • The app linked will not install on a Venue 8 Pro.  Only on a Venue 11 Pro I think.

  • That is regrettably true. I have a 11-inch model, and it worked like a charm there. But the good news is, StayTuned and rcciren have combined my advice on updating the BIOS on the 8-inch model (can be found in the thread) and a priactive way of starting the system with the Power button pressed until the Dell logo shows up, and it worked for them. So you should give it a try!


  • yea mine says venus 8 pro. nice an official Dell knockoff from dell. Big Smile

  • Glad to hear the power button hold worked.

    MDUSEN1216 - good to know I am not crazy Tongue Tied

    I was worried Staples received a bad batch of Venue's. Dell may want to warn people about this - I am sure others are going to be worried it's an actual knockoff!

  • There is no software for the Venue 8 Pro.  I even tried the software link and that will not work either.  Seems to be a fix for the 11, but not the 8

  • anyone found a solution for this that works?  I am on BIOS A04.  Ran all the windows updates and dell driver updates and I am at 6% battery and cannot charge when on, off, standby etc.  I turned it off now to preserve the last 6% battery but this is really frustrating...

  • Hello,

    To cut it short, I MIGHT have found a solution, and it's a weird one: Looks like the FAULTY USB CABLE shipped with the power adapter is the culprit. Having tried everything else and all combinations of tricks (and I also have two keyboards, a slim one and the one with a battery inside), I've discovered the two that work.

    And the first one is REPLACING THE CABLE SUPPLIED WITH A GOOD ONE. For some reason my Dell Venue 11 Pro immediately started charging as soon as I tried a cable purchased at I do not think that the brand plays any role, but mine is Mediabridge 2.0 Micro-USB to USB. No more tricks so far, and it's been at least 5-6 attempts at recharging it - everything has been stable. So I might imagine that they've got a large stock of faulty cables, and now all of us are scratching their heads in amazement. I can't guarantee it, but it works for me. When I am using the standard cable supplied, it might charge, but in most cases it doesn't...

    The second one is for those who do have a detachable keyboard: Even the standard cable starts charging the device if you "closed the lid" (keyboard) AND LET IT SLEEP FOR AT LEAST 15 MINUTES WITHOUT INSERTING THE CHARGER CABLE! For some reason after that the sleep gets deep enough :-), and the LED miraculously lights up, and the whole thing starts charging even with the standard cable supplied. The problem is, unless you've got a keyboard to make sure that the computer is sleeping while being charged, you simply can't reproduce these steps: As soon as you insert the cable, the screen lights up, the device awakens, and no charge :-(


    Good luck! And let me know whether this sorcery works for anyone else besides myself!


  • I called Dell and they are sending me a replacement unit.



  • Hi DON, complete I was having the same issue as the person above. on another note. there is a problem witht he wifi completely being disabled when updating windows. please look into this. it is very frustrating.


    I noticed that this issue is over other forums with no solution.

  • I had the same problem and now, 15 days past when I reported the problem and was told that I would get a replacement in "7-10 Days" I am just told that it will be another "10 Business Days"  that means I'm without the device for 30 days (or more) and only got to use it 3 days... What a rip-off.

  • Same exact thing happened to me.  Purchased the 64gb version from Amazon, plugged it in and it stated plugged in but not charging.  So I came here to see what was up.  Did the updates but nothing worked.  Luckily I still had a 32gb Venue 8 pro handy because I was returning it because I needed more space.  I swapped out both the charging brick and cable and bingo, the 64 GB one started to charge.  Since I didn't swap each piece, not sure which it was but it did fix it.

  • I'm also having the problem with my Dell 11 pro.  I have not changed the included charger or cable.  I also bought the portable keyboard dock with built in battery.  The first three days my tablet and keyboard charged perfectly now nothing.  I can plug it in for five hours now and it just stays at around 30%.  Plus no charge even makes it to the keyboard now.  I installed the power manager 1.1 and changed the setting to standard.  It still is not charging.  The icon on the screen shows that it is indeed plugged in but there is no charge progress...  

    Very frustrating...

    Help is very much appreciated.  Do I need to buy an even more powerful charger than the one included? That just seems me



  • 1. Overall, this does not look like a hardware problem or a power adapter limitation. It looks like a firmware one...

    2. The is no permanent cure, methods I have found do work, but not at all times, and one never knows when the system is going to stop charging again.

    My observations and charging tricks:

    1. Try using a different, high-quality USB to Micro-USB cable. It helped me a lot, and with a different cable charging becomes more reliable, even though not AR 100%

    2. Remember that the power adapter  supplied has large capacitors inside. Unplugging and re-plugging the adapter immediately, while the LED indicator is still glowing, might result in the computer not charging, however weird it might sound.... Personally, I am waiting for 20 (!) minutes between unplugging and replugging the adapter.

    3. When using the battery-equipped keyboard, remember to put the computer tot sleep (by quickly pressing the Powered button) before connectiiing orrr disconnecting the keyboard. For some reason not doing this often results in computer not  charging...

    4. What typically works for me:

    - Start or wake up the computer with or without the keyboard, but with NO CONNECTION TO THE POWER ADAPTER. Then connect the adapter. Typically that way the led at the top lights up, the computer starts charging, and it charges both batteries. You can close the lid/put the computer to sleep as soon as the charge process has begun.

    - Sometimes it also helps if you leave the lid closed (I mean the keyboard) with the capable DISCONNECTED, let it sleep for at least 20 minutes, and then connect the cable while the computer is sleeping...

    Overall I've been able to charge it reliably using these tricks for two plus weeks in a row, but the result  is never guaranteed. Which means that I am exchanging mine as soon as I am done with businesses travel and vacations. I am quite irritated, but not in a hurry, because I AM NOT SURE THAT A NEW COMPUTER TRTHEEEY SEND ME WILL BE ANY DIFFERENT... Waiting for Dell to come up with a real solution...