New XPS 10 firmware or Windows RT update have ruined two XPS Tablets today.

Mobile Devices

Mobile Devices
Mobile devices Hardware and Software discussion

New XPS 10 firmware or Windows RT update have ruined two XPS Tablets today.

This question is not answered

First off, the lucky XPS 10 owners that downloaded the new updates that systems work the same, well I wish I were you guys. I however didn't get out so lucky. Here is my story.

I got a replacement XPS 10 Tablet in the mail today that seemed to work fine. Then I updated the Firmware that came out today and the new Windows RT Updates and anytime I shut it down or restart it the system hangs on the shutting down screen for over 5 minutes until it shows a Windows Blue screen that says Driver Power State Failure and then it reboots itself. It can do this 10 out of 10 times rebooting or restarting or not do it for 2 or 3 times. It's so random.

I've removed everything and reinstalled windows and it will reboot and shut down fine. That is until I install Dell's latest firmware and the Windows Updates, then it's back again! I was told that it wasn't the firmware and it might have been a problem with that tablet and it's preinstalled software. Fine, I can buy that.

That is until my previous Tablet that I'm supposed to send back to Dell (Screen had been flickering and needed rebooted often but other then that, it works fine) downloaded and installed the firmware and Windows updates. Then now it won't shut down and reboot with out showing the exact same screen. Funny how it's worked for weeks and NEVER has had a problem rebooting or shutting down until those updates installed. I won't believe the updates aren't the problem because then why else would a factory fresh Tablet work until it was updated?

What is so odd is sometimes both of them will shut down or reboot and not do anything, almost fooled me into thinking it was a glitch that had fixed itself until BOOM, it shows it's ugly face. Sometimes it could do it 10 out of 10. I've made two different videos showing them doing it. I had decided that I could still use the tablet and just not shut it down but now they are doing blue screens and freezing while in use, what gives?

I decided that I could do a factory refresh and not install the new updates but now I can't even do that as the second video will show. Now they crash now matter what I do and are both useless. I need these for work and school and now I have a replacement Tablet that is worse then the previous.

I'm at a loss here and I'm so frustrated I don't know what to do.

Here is just to name a few of the glitches and crashes I've had in the past month.

1. Screen will flicker so badly I have to reboot. Happens 3 or 4 times a week.

2. Side screen moves back and fourth causing a reboot.

3. Windows crashes at random when using an SD Memory card that has been freshly formatted or has files. It says Watch Dog Error.

4. When going into sleep mode and it doesn't matter how much battery life the tablet won't power back on unless I hold Windows Button and Power Button over 10 seconds.

5. Now the lovely Error Driver Power State Failure.

The first time I updated the newest Tablet it showed a Display Error when updating Windows and I thought that was the cause. However after updating both tablets multiple times, that never reoccured. So I don't believe it was related and was just random, as is alot of things on this Tablet.

I'm at a loss of what I should do as it's to late to call Dell tonight and I'm afraid another replacement will be the exact same thing. I've had this tablet since the 4th of Jan but is it still possible for Dell to give me a refund because I currently have no faith left in this Tablet. I mean to have a replacement Tablet and the previous Tablet both setting here in this state frustrates me beyond belief!  I've been a customer for Dell for over a decade and I've purchased XPS products since 2006 and it seems I've had nothing but trouble but I kept on buying from Dell.

Either way the proof is in the videos.

All Replies
  • With luck I finally got both tablets to format. It took like 5 attempts.

    Now without all the new firmware and Windows updates they seem to work fine. Rebooting and restarting without error.

    Now the question is, what to do from here? I don't dare reinstall updates. I've thought about just installing Windows Updates on one without the Firmware update to see which is the problem. I will keep an update on my findings.

  • So apparently the A03 12-28-2012 Firmware is still on both Tablets even after a format.

    There is another Firmware update called System Firmware Update 2/12/2013

    I installed it on a fresh formatted Tablet. It was rebooting and restarting fine after I formatted it. Now as soon as it's updated with the 2/12/2013 firmware it won't reboot or restart without the error.

    The other XPS 10 after installing all Windows Updates except the Firmware update restarts and shuts down fine.

    I believe it's the new Firmware.

    What is confusing is the older Tablet shows the firmware update called 2/12/2013 which is around 43 mb on one Tablet but shows up as only 17.9mb on the other one? Either way I'm hiding that piece of crap for now.

  • So no one but me is experiencing this issue? I'm updating Windows only on one of the tablets and I'm not going to install System Firmware Update 2/12/2013. The system I installed the Firmware is sometimes shutting down or restarting but freezing most of the time and giving that blue screen. I finished all the Windows Updates on the one with the firmware and it still acts the same. It's the firmware and I don't care how much systems you tested it on because I have proof of two freshly formatted Tablets that worked fine before that update.

    I've tested them multiple times. The one that only has Windows updated apparently works fine.

    I haven't had a chance to call Dell yet because I've been trying to trouble shoot and find out the problem before I have to talk the people over seas. It's going to be a great hassle.

  • Also here is what else I'm experiencing at least once or twice a day.

    I'm to my wits end. I'm wishing I had bought another Tablet. If I'm stuck with this Tablet and aren't able to get a refund, well I'm going to be very upset. After all 550 dollars after tax and shipping isn't anything to be snuffed at. Dell should at least help me fix this situation or partially refund me some money after all the stress and hassle of dealing with this considering the tablet was bought in the first place for work and school.

  • Having similar issues with the XPS 10 I purchased. It has the latest BIOS and firmware. Only difference is that, after a factory reset, the tablet seems to work fine now. It only hangs on shutdown, or restarting when it is docked in the keyboard/dock. I have called tech support and they are replacing the dock.

  • Sorry to hear you're experiencing something similar. Keep me posted on what happens after you receive your new dock.

    The Tablet that I kept is working fine because when I formatted it back to original factory settings I didn't download the firmware. Before I sent back the other Tablet I did the same to it, just formatted without firmware and it worked. That's including all Windows Updates. However When I'd download the firmware on either of them, boom, wouldn't reboot or restarted unless it did what's in the videos. Granted sometimes 2 out of 10 it would restart normal but it was so random.

    Now I'm using a 500 dollar Tablet that I'm afraid to download firmware on, that's just unsettling. The Dell tech's I've spoke with are from Indiana and don't see to really know what I'm talking about. They don't bother to watch the videos to understand. They just read from a script and ask me to try things I've told them to try. Like ''have you downloaded the latest firmware'' haha

    I mean wow!! The firmware is the reason why this happened. Dell can speculate how they want but I had two different tablets to try this on. I did it at least 10 times with in a week and they work fine with all the Windows Updates and reboot fine dozens of times but as soon as I downloaded the firmware on both, they wouldn't reboot correctly. It was just so random though. Sometimes both would crash over and over and then sometimes one would crash while the other rebooted and then vice versa.

    Never once did they crash only using the Windows Updates.  So I've resorted to just not downloading a firmware, which kinda of sucks. I really enjoy this Tablet (without the firmware of course) so I'm hoping at some point this will be resolved.

  • I am having the same issue with Shutdown/restart. The problem appeared the first day I got the tablet out of the box (this past Tuesday), spent a while on the phone with Dell CS trying to solve this issue, did a factory reinstall and it seemed to function normally  for about 24 hours then this morning resurfaced. Currently waiting on a call back from CS. I seriously doubt that another factory reinstall will permanently solve the problem, as I as anticipating they will suggest.... all that will really do is give me the aggravation of a 3rd round of re-personalizing the tablet and reinstalling apps.

     Uhhg. Paying $550+ for a headace is too much. If this RT on Dell XPS tablets is so unstable it should not be on the market.

  • Replacing the dock fixed my issue. All seems to be well now, even with new firmware loaded.

  • I dont have the dock, tablet only. I think I might be hosed. Iv been looking around online while waiting for CS to call and gotten nowhere. Also had a blue screen while the tablet was on about 15 min ago, sudden shutdown saying "SOC SUBSYSTEM FAILURE"

  • I'm so sick of Dell and this Tablet. Well even though I hid their TERRIBLE firmware update, guess what? One that came out this month automatically downloaded and guess what? My tablet won't restart or shut down now. It's doing the exact same thing. It's been working fine the last month or so since I did a factory refresh and hit the firmware. Since this new firmware has came out, I didn't know and Windows automatically downloaded it and now I can't shut down and I'm going to have to do a factory reset. I'm so sick of the <profanity> and I 100 percent regret getting this tablet. I've had nothing but problems out of it and it was a bad 550 dollar purchase.

  • so <profanity> is profanity?


  • I am trying to reset/format to factory setting, but it is asking for recovery media. How did you succeed in formatting?