Dell 15R (5521) Catalyst continuously crashing, cannot use switchable graphics (HD 8730M) option, Windows 8 Pro 64bit

Laptop

Laptop
Laptop computer Forums (Audio, General Hardware, Video)

Dell 15R (5521) Catalyst continuously crashing, cannot use switchable graphics (HD 8730M) option, Windows 8 Pro 64bit

This question is not answered

im having this problem, i bought new dell 15R 5521 two days ago

All Replies
  • yes im also having the same problem..with my a week old 15r 5521...i also re installed the ccc then after 1 or two day while editing the setting in ccc it started crashing again..m really disppointed with this and hoping that dell representative will answer this..

  • Hi pawanM,

    I recommend you to uninstall the AMD driver from the device manager and uninstall Catalyst Control Center from Program and features. While deleting the driver from the Device manager, make sure you check the option “Delete the driver software for this device.”
    Restart the system and install the driver from the support website. Click on the link below, enter the system service tag and click Submit. Select the Operating system from the drop down list to get drivers for your system model:

    http://dell.to/14Xsnmd

    Restart the system and check. Let me know the status.

    Thanks and Regards,
    DELL-Sujatha K
    Dell Social Media and Community Professional
    #iwork4Dell
    Order Status
    Download Drivers

  • thank you for reply,

    I have done xactly wat u told....now its continuously restarting and now m unable to do anything

    what should I do now ..?please provide suggestion which does not create more problems

    I want my time should be go into using it not continuously reparing it....

    and for god sake its a brand new laptop

     

  • Hi pawanM,

    I assure you that updating the video driver will not cause the system to restart continuously. I suspect now the issue is different. Please run diagnostics on the hardware components of the system. Refer to the following link for assistance:

    http://dell.to/16KQ3r0

    Reply to this post in case of any error message.

    Thanks and Regards,
    DELL-Sujatha K
    Dell Social Media and Community Professional
    #iwork4Dell
    Order Status
    Download Drivers

  • Try deleting the the ati folder. It is in User/user_name/AppData/Local. 

    replace user_name with your own.