Forums

Laptop

Laptop
Laptop computer Forums (Audio, General Hardware, Video)

Dell Inspiron 15r Catalyst Control Centre Problems

This question is not answered
Hi, I purchased a Dell Inspiron 15r laptop in 2012 towards Christmas. I have AMD Radeon HD 7730M graphics card that came with it and windows 8. And ever since I started to change the Catalyst Control Centre settings for my games to run faster it does not work any more. When I try and open Catalyst Control Centre it comes up with a message saying; Catalyst Control Centre: host has stopped working. I got into contact with AMD and they gave me instructions as followed; 1. Start computer 2. Uninstall ATI or AMD Catalyst install manager software from add or remove programs/ programs and features (if possible) 3. Run Windows in its regular mode 4. Try using a driver cleaner program to make sure the drivers are removed: a. Driver Cleaner Professional ( select ati ccc as the cleaning selection then click add and start) Then they said download and install this driver from dell: http://www.dell.com/support/drivers/ca/en/cadhs1/DriverDetails/Product/inspiron-15r-se-7520?driverId=RH19N&osCode=W864&fileId=3080387755. I installed it and it worked until I tried adjusting settings for my games again in catalyst control centre. Please help me out I really don't know hat to do anymore. And please don't Tell me to stop opening catalyst control centre cause I have to in order to get games to run smoothly, it's the reason I bought this laptop to play games
All Replies
  • Hi Angus.Wrightson,

    Please check this thread. We have replied to your post.

    Thanks & Regards
    Zohaib R
    #iworkfordell
    To know more about Dell Product Support, Drivers & Downloads, Order & Dispatch status -> choose
    your region US Customers; India Customers. For Dell support videos click Here.