Dell Inspiron 14z - plugged in, not charging - charger light is green - help?


Laptop computer Forums (Audio, General Hardware, Video)

Dell Inspiron 14z - plugged in, not charging - charger light is green - help?

This question is not answered

My Dell Inspiron 14z (N411z) is less than a year old. I received it in June or July of 2012. Several days ago, after I exited a game I had been playing, I noticed that the battery was very low, even though it had been plugged in for hours. It said it was "plugged in, not charging" and it was at 7%. I decided to leave it be for a little while, thinking that maybe my laptop got overheated while I was playing the game. But it was still like that after an hour or two, so I tried restarting, then shutting off and on again, but neither of these things worked. I tried shutting it off and taking out the battery and leaving it alone for a few hours, then putting the battery back in, didn't help.

My father and I struggled with it while I tried to find solutions online. We struggled with the cords to see if there was some issue with the charger or wires, but my guess is that it must be the battery or computer if the charger has a green light (I assume that means it is working properly?). The information I found on various forums, including this one, was confusing and vague to me, and usually mentions a red or orange light flashing. I don't see any red lights on my computer or charger. I saw people saying that to fix my problem, I'd just have to take out the battery and put it back in, but I already tried that several times (I even take out the battery overnight now to let it rest and see if that helps - it has no effect as far as I can tell).

One suggestion was to reinstall my OS, which was Windows 7. I tried that, and it helped! But only for a short while. It charged up to 11% before going back to "plugged in, not charging." At the end of the end of the day, I followed another suggestion I'd seen in a forum: unplug the charger and let the computer die. I did that and took out the battery. The next morning, I put it all back in and it was charging again. This time it charged up to 9% before stopping.

I am currently using Ubuntu 12.10 as my main operating system. Yesterday, I installed Ubuntu over Windows (not necessarily because of the battery/charger issues, although I was hoping to see it work). It had no effect on the battery, which is still at 9%.

Does anyone know what might be wrong with my computer/battery/charger and how I can fix it?

All Replies
  • Hi Tea4649,

    This problem usually occurs if there is an issue with the charging port or the motherboard. Please check if the charging port on the laptop is loose. Connect an alternate AC Adapter to see if that works fine with the system. Alternatively, try the steps mentioned below:

    *Check the AC Adapter in BIOS; check the ‘AC Adapter type’ status if it shows ‘Unknown/  Not Detected / 65W / 90W / 130W'.
    *If you get the status as 'Unknown / Not Detected' then reset BIOS to defaults:

    • Restart the computer, tap 'F2' key on Dell logo 4-5 times
    • This will take you to the main screen of BIOS
    • Press ‘F9’ key once, highlight ‘Yes’, press ‘Enter’
    • Press ‘F10’ key once, highlight ‘Yes’, press ‘Enter’

    Also, check the Battery Health Meter:

    • Right click on the battery icon on the taskbar
    • Choose ‘Dell Health Meter’
    • Click on ‘Battery Health’ tab
    • Examine the information shown in the window

    If the Battery is 10%> or >10% charged, you may try to perform BIOS update from the following link 
    Please ensure that:
    *AC Adapter should be connected 
    *No external devices (flash drives, printers, external hard drives) should be connected.
    *All other programs should be closed and documents saved 

    Please reply if you have any questions.

    Thanks & Regards,
    Appu S
    To know more about Dell’s Product Support, Drivers & Downloads, Orders & Dispatch status -> choose your region USA, India. For Dell Support Videos, click Here.

  • Hello, It's telling me my battery is "less than" 10% so I can't download the BIOS update. I'm having the same problem, My 14z laptop is failing to charge right now.

  • Check your BIOS setup - if the AC adapter is listed as "unknown" or "not present", the battery won't charge.

    First thing to do is try a new OEM Dell AC adapter.  If it doesn't fix the problem, try replacing the DC jack:

    If that doesn't solve the problem, the mainboard needs to be replaced.

    This is not a BIOS issue - and a BIOS update will not correct it.  It's a hardware problem with the adapter, jack or mainboard.

  • How do I check my BIOS setup? I had the same issue a while back where the charger icon on my laptop said  "plugged in, not charging" . All i did was update the BIOS and it started charging normally again. Now my computer is failing to charge more than 7% . it's saying I need to be at 10% for the Bios update.

  • So appu, you are telling me i must replace the entire motherboard just because it cannot longer recognize the AC adapter? even when it and the rest of the computer works fine? im mean, i can live with the fact of the battery cannot be use anymore, but since this, my computer if so slow, please can you just deactivate this feature in the bios? 

    PS. Me neither can update the bios because my battery is 0%!!!