Forums

Laptop

Laptop
Laptop computer Forums (Audio, General Hardware, Video)

Latitude E6420 won't turn on

This question has suggested answer(s)
Hi all,
I have a Latitude E6420 that won't power up. When I press the power button the laptop starts running but nothing loads on the screen, the fan is spinning at full speed for 10 sec. and then the entire laptop shut down. So far I tested the ram, power brick, and the hdd and they work just fine... Maybe is the motherboard? Or the cpu? Any other suggestions guys?
And since my english is sooo good here's a video of the problem I'm having



Thanks!
All Replies
  • Hi johen,

    Do you hear Windows sound when you power on the computer? 

    You may drain out the residual power and then try using the system:

    • Power off your computer.
    • Please remove the AC adaptor and battery of your computer.
    • Press and hold the power button of your computer for 10-15 seconds to drain out the residual power.
    • Release the power button.
    • Insert the battery in and connect the AC adaptor.
    • Then try powering on the computer. 

    Another step you may try is to check if the computer works perfectly fine with external monitor. You may also check the status of diagnostic LED's on your computer. 

    Diagnostic LEDFault Description 
    Hard drive LED 
    Power LED
    Wireless LED
    Blinking
    Solid
    Solid
    A possible processor failure has occurred.
    Solid
    Blinking
    Solid
    The memory modules are detected but has encountered an error.
    Blinking
    Blinking
    Blinking
    A system board failure has occurred.
    Blinking
    Blinking
    Solid
    A possible graphics card/video failure has occurred.
    Blinking
    Blinking
    Off
    System failed on hard drive initialization OR System failed in Option ROM initialization.
    Blinking
    Off
    Blinking
    The USB controller encountered a problem during initialization.
    Solid
    Blinking
    Blinking
    No memory modules are installed/detected.
    Blinking
    Solid
    Blinking
    The LCD encountered a problem during initialization.
    Off
    Blinking
    Blinking
    The modem is preventing the system from completing POST.
    Off
    Blinking
    Off
    Memory failed to initialize or memory is unsupported.

    Please share the findings. 

    Thanks and Regards,
    Chinmay S
    #iworkfordell 
    To know more about Dell’s products, services and drivers & downloads, please go to http://dell.to/10GaKAc  

  • Hello DELL-Chinmay S

    Ive already check the battery, ram, hdd. I also remove the bios battery to reset is and there is no signal to external display.

  • This happened to mine in Jan. Laptop was returned to dell. They were not able to fix it.  As it was under extended warrenty, they ended up replacing it.

  • Hi johen,

    Did you check the status of the diagnostic LED's as mentioned in previous post?

    Most likely it appears to be an issue with motherboard of your computer. If the computer is under warranty, you may private message me the service tag of your computer. I have added you as a friend. Please accept my friend request by clicking on my name highlighted in blue and then click on “Friends” tab at the top and then click on “Request to Review” and finally click on “Accept” button.

    I am sending you a private message as well. Click on “Inbox” to respond to the message and provide system’s Service Tag and contact details so I may access your system records and check for further course of action. You could also click on Start Conversation to send a private message.

    Please reply with information. 

    Thanks and Regards,
    Chinmay S
    #iworkfordell 
    To know more about Dell’s products, services and drivers & downloads, please go to http://dell.to/10GaKAc  

  • i have just experience this with my DEL, i follow the suggestion to drain the remaining power and then plug the battery in again and AC then power up. still nothing on the screen, but the LED indicators was SOLID - BLANK - SOLID for a while, then became BLINK - BLANK - SOLID.. ?? i'm confused on what to do, i was still working on it last Saturday, and haven't used it for the whole day, and in about 24 hours later this happen.

  • I have been experiencing this with a E6420 at my work.   Heard that it may also be related to the LCD cable that goes through the hinge.   I tapped the hinges while it was off, opened the screen and started it up.  Not a solid fix, but may allow you to get to your data to backup if need be.