17R SE 7720 New A12 BIOS Update Corrupting Boot-up Device Table!?!


Laptop computer Forums (Audio, General Hardware, Video)

17R SE 7720 New A12 BIOS Update Corrupting Boot-up Device Table!?!

This question is not answered

Dell should be aware that their new A12 BIOS update appears to be  destroying the boot-up device  UEFI  priority table for this model, posted 14-Jan-14. I contend that this is why many people are complaining a RESTART hangs and requires two power ups to boot after loading BIOS A12.  The 1st boot can not find the desired boot device and then the failsafe code in the 2nd boot seems to finally default to the C: drive in bay 1. I tried to add the device table back in but the BIOS is locked up by Dell and there is no manual at all for this computer explaining the BIOS entries (for any version) on how  to fix it. I reloaded A11 and same symptoms (yet A10 & A11 was previously perfect in that they retained the 3 items in the boot priority list) so the table had to be destroyed by A12. The Legacy (MBR) mode device table seems to be present but that really is for CD/DVD boots with a legacy MBR disk only. 

The question is:  How do we add entries into the BIOS Boot priority list?  There are absolutely no manuals or advise on this for BIOS A12.  I gather BIOS A10 which came with my computer was not locked  out by Dell  but  now  Dell took A10 off the download list such that no one can go back according to other posts!!

We are  expected to be "mind readers" of the software engineers at Dell & Phoenix!   I put in my Service Tag and the Dell site now says there are "no manuals" at all now for this computer. Even the "maintenance manuals" that used to be there are all gone as though they never existed. Good thing I saved them, but good luck to new purchasers. There never was a User Manual and that must be a first for any laptop ever made. All I can say is Dell is going to have a mass of returns as there is no way I can communicate this problem to Dell other than  by this overloaded blog that may be looked at in two weeks or more.  Now that I have unloaded the negative aspects,  I would like to say the new BIOS diagnostics are very good as it identified one driver that was not correct because latest version  was listed under "previous version" in the drivers section.  By the way, the computer works great otherwise after many hours poking  in the dark with NO User Manual, otherwise and I just wish we would not go backwards like this. Google has been my User Manual instead.

Note after no Dell acknowledgement for a day: I do not expect an instant solution but please acknowledge that the problem is being looked at. If others are having the same problem, I suggest they start their own post as I have yet to get an answer from a Dell employee on anything I have brought up. I am beginning to think I am on a "blacklist". I am thinking of the problems like: 1) absolutely NO User Manual, 2) a repair disk utility that keeps writing bad DVD disks, 3)latest disk drivers buried under "previous version" & visa versa, 4) a SATA II drive in a SATA III capable machine (halves the boot-up time for $5 more)  and now 5) BIOS corruption and the many hours wasted on this thing to make it work, and I am starting to think I should get rid of it and buy a Toshiba like I have had five times in the past with NO problems. Plus if there is NO support coming , that is the last straw.

I feel better now but I would feel  even better making a movie of this computer under the tire of my diesel truck and see how many Youtube hits I get.

All Replies
  • Bill,

    Had a nice long Chat session with Dell Tech support - who of course wanted to replace my Motherboard because of the same exact issues that you nicely detailed here. I of course explained that it would be of no use and a waste of my time, Dells Money.  I gave them the link to this post and a few others on here and stated it's exactly what I'm seeing as well as others and asked to escalate the problem to engineering.  Engineering stated to the support rep that there was no change to the A12 BIOS that would lock us out.  OK I may believe that NOT, but it's possible somehow the BIOS was corrupted inadvertently or by accident that caused the lockout and posted by them.

    In my session I asked specifically for her to instruct Dell Engineering to send a representative to the General Laptop Hardware Forums and to please respond to the numerous posts about the 7720 no access to BIOS or multi-boot issues.

    Stated I'm not only a Dell customer but I also have many medical field clients via my Business that I usually advice to purchase Dell products, if this is what is now to be expected with newer products I'll just lead their business to my 2nd and 3rd choices of Lenovo and Toshiba.

    Lets see how they respond.



  • I can't believe it. They locked our bios!

    I bought a Dell 17R SE 7720 thinking it was the notebook which best suit me, but i was actually wrong.

    I hate locked things.

    I will hopefully waiting for further updates.

  • CyberMaxX360: Perfect response!    At least you got the action going.

  • I am experiencing the same issue "RESTART hangs and requires two power ups to boot " I am making this note to encourage Dell to escalate resolution of this issue

  • I tried twice to upgrade to A12 thinking it was a connected device.

    It hangs on boot-up on the dots spinning in a circle.  It happened both times!

    A12 is garbage.  If it does not hang then the OS is unstable and hangs eventually too.

  • OK dumb question for you guys. I just got my 7720 with A12 on it and it runs perfectly fine. I do however would like to change my boot drive order. You are saying I can't do that unless I have A10? Can I change my bios from A12 to A10 if I can find it?

  • If it is fine, leave it. I think the problem is the flashing process that loses the  linkages  with Win8.  A13 is coming in April/May so I would  not touch the BIOS and especially do not go backwards. They warn about going backwards on the last step of flashing since the BIOS is only forward compatible.  I think it is because it reads some user unique parameters to merge with the new version before flashing. A10 is totally gone. Believe me as I have the F2 F12 problem also and I have lost my boot table but found ways to get around it until A13.

  • @Bill Alsip

    A temporary solution to the 'twice reboot' problem is to create an empty boot option to the hard drive in the BIOS by  Boot->Add Boot Option->Yes. I have an Inspiron 5720.

  • Funny enough, after owning my 17R for 4 months all of a sudden I can't get into the bios?? There was some windows update done last night, and now my backlit keyboard is no longer working or my quickset buttons. With the win +x trick I get into it and it says my keyboard light is ON. I deleted the updates and reverted back, still a dark keyboard. WTH dell?