Random freezing and internet wont connect.

Laptop

Laptop
Laptop computer Hardware and Software discussion

Random freezing and internet wont connect.

This question has suggested answer(s)

I have a Dell Inspiron 1525 and its about a year and half old. So anyways for about 3 months now ive been having major issues with this laptop. If im on my laptop for about 30 minutes and nothing moves or anything the computer completely freezes. after a little while of no activity ill come back and if i click like inside of firefox itll say not repsonding then everything will freeze except for my mouse. forcing me to manually restart. even if i have music playing after about an hour it will just freeze and i have to manually restart again. and NOW my computer just likes to not connect to the internet whenever i turn it on. It will connect to my wireless network with no issue but it wont reconnect to the internet. no it is not my router or internet because i have other computer in the house that can connect perfectly. it will connect but local only. and sometimes ill have to restart it upwards of 10 times for it to finally connect to the internet. this is honestly the most annoying thing and i cant find anyway to fix it. it seems that every time i figure out a way to fix it, it works once then never again. i thought just logging off when im done would work but that stopped after once or twice. i tried disabling the radio through the wlan utility and that worked once. PLEASE i cant even call dell because of the ridiculous prices they charge. PLEASE HELP ME!!!!!!

All Replies
  • Hi Sillyzak,

    Welcome to the Community. Looking into your symptoms I guess you have a Virus infection on your computer. I would suggest you download Virus removal program, which you can download for free off the internet, and run a scan and remove all the infections. If this does not work, I would suggest you to backup all your data, and reset your computer back to factory settings. Use the below link for more information on how to restore your computer to factory settings.

    http://support.dell.com/support/topics/global.aspx/support/kcs/document?c=us&l=en&s=gen&docid=DSN_336966&isLegacy=true

    Hope this helps.

    Thank you

    Royan