Windows 8 on Dell Latitude D630: Sigmatel/IDT sound drivers not working with docking station

Laptop

Laptop
Laptop computer Forums (Audio, General Hardware, Video)

Windows 8 on Dell Latitude D630: Sigmatel/IDT sound drivers not working with docking station

This question is not answered

I have a Dell Latitude D630 and Windows 8. The generic Windows sound driver made the sound for the laptop run, but not with the docking station. I installed the Sigmatel drivers for Windows Vista 32bit. They also worked for me on Windows 7. First, they didn't wanna install, but then I made a BIOS update from Revision A03 to A18 and it solved the problem. Now again I have sound for the laptop, but when connected to the docking station the following happens:
When I set the normal speakers as output: Sound starts to play through the speakers connected to the docking station, but aborts quickly (for example the Windows sound when changing the volume).
When I set the SPDIF out as output: No sound at all!

The Sigmatel website obviously doesn't provide drivers since it's not existant anymore. The audio business was sold to IDT, but the IDT Website sucks: Detailed descriptions of all sound cards, but no drivers at all!

There was an IDT modded drivers section on laptopvideo2go.com before, but unfortunately the project is dead. I can't even find the uploaded files anymore. Anyway, one doesn't know if it works for Win 8 at all.

Audio device:
STAC9205

Device-ID:
HDAUDIO\FUNC_01&VEN_8384&DEV_76A0&SUBSYS_102801F9&REV_1002\4&C38AAC3&0&0001

I tried the following drivers from the Dell website already which according to Windows 8 work, but give me the described sound problem:
- 2Y0VM
- R153997
- R171788
- R171789
- R218148

Any ideas how I can get this to work? Any other IDT drivers available?

All Replies
  • Purchase  driver detective. it sorted my dell d630 out quickly.

  • The program is not running on mine, giving out errors. If you are using Windows 8 as well, could you tell me which driver "driver detective" installed for you?

  • Go to the Microsoft Catalog and Search for Sigmatel STAC

    HDAUDIO\FUNC_01&VEN_8384&DEV_7627&SUBSYS_80863001&REV_1002
    HDAUDIO\FUNC_01&VEN_8384&DEV_7627&SUBSYS_80863001

     catalog.update.microsoft.com  

    This one might work also

     

     http://ftp.hp.com/pub/softpaq/sp47501-48000/sp47902.exe

    Report Unresolved Customer Service Issues here:

    Dell - Unresolved Customer Service Issues

    I do not work for Dell. I too am a user.

    The forum is primarily user to user, with Dell employees moderating.

  • The file found for that ID in the Microsoft catalog is a CAB file for Windows XP. It doesn't open.

    The HP driver says it's not compatible with my device during installation.

    I tried Intel drivers as well, not working either.

  • Hi SnerBeyond,

    i have a dell precission m4300 and did a new installation win8x64. My previous installation was win7x64.

    Default installation win8 left me with a generic sigmatel device, playing sound via machine speakers when docked and not on the docked devices.
    The same procedure that helped me on win7x64 years ago, helped now again:

    I updated drivers with  dell R171788 provided for vistax64:

    Title      : Audio:SIGMATEL STAC 92XX C-Major HD Audio Driver
    Version    : A09
    OEM Name   : SIGMATEL
    OEM Ver    : 6.10.0.5614
    Computers  : 130L, MXC051, M1530; 1420, 1501, 1520, 1521, 1720, 1721, B120, B135/1400, ME051, MM061, MP061, MXC061; Latitude:120L , 131L, ATG D630, D420, D430, D520, D530, D531, D620, D630, D630c, D631, D820, D830, XT; Precision:M2300, M4300, M6300, M65, M90; Vostro Notebook:1000, 1400, 1500, 1700; XPS:M1330, M1730, MXC062, MXG061, MXP061
    OS         : Windows Vista 32-bit, Windows Vista 64-bit

    did a reboot and sound does fine now.

    another problem with unknown modem hardware  "Dell Wireless 5520" i solved the same way with dell R216764 (x64 vista version)

    I hope this will help you with win8x86 too.

    Regards

  • Thanks for posting, but I tried this already and unfortunately it doesn't work for me. Seems to be not working for Latitude D630.

    All I want is the docking station headphone jack to work so I can get sound from my external speakers without plugging them on and off the laptop itself all the time.

  • Hello Snerbeyond, I have exactly the same problem, I've been researching but I have not found a solution. Have you fixed the problem? If you get it, can you explain how?

    Thanks.

  • Hi fsego,

    unfortunately the problem still remains.

    What I am doing for now is use an external PCMCIA soundcard (Echo Indigo I/O) where I plug the speakers in. Not really satisfying because I have to remove the soundcard everytime I dock the laptop off the station, so it's not much of a difference compared to just pluggin the speakers into the laptop directly. But at least the drivers are slightly better than the Sigmatel ones. I noticed the following issue in the Sigmatel drivers: The software volume (for example in a music player, I use MusicBee) can only be increased up to half. If you increase it higher, the sound doesn't get louder, but only slightly overamplifies. Do you have the same issue or is it just my device?

  • Hi, thanks for you quick response.

    I don't have the issue with the volume,  it is working ok.

    I think I will continue plugin the speakers directly to the laptop. Anyway, If I find a fix to the issue I will post here for your knowledge.

  • I had an issue with the SigmaTel drivers in Win 8 pro

    I looked at and tried most every driver I could find online.... none worked -- I kept getting 'device not found' errors

     

    I noticed the other day that because I installed Win 8 as an 'update', there was a "windows-old" folder on my C drive.

    So for giggles, I navigated thru the windows-old folder to find Program Files ... and then a Sigma Tel folder and saw the old files from when I was running XP..

    I went to Device Manager, selected Update Driver Software for the device, pointed it to the WDM folder in my Sigma Tel folder ..... voila ... I have sound!!!

  • Hi Snerbeyond, any progress on getting the sound from the docking in windows 8?

    I have the same exact problem.

  • if you go to Microsoft update catalog http://catalog.updat...arch.aspx?q=idt enter in Sigmatel you'll find drivers to chose from.

    Report Unresolved Customer Service Issues here:

    Dell - Unresolved Customer Service Issues

    I do not work for Dell. I too am a user.

    The forum is primarily user to user, with Dell employees moderating.

  • This driver was needed to solve my audio problem on my Inspiron 1520. I installed Windows 8 64bit, VLC player, and CCCP codec pack but was having glitchy audio. I installed this driver and it fixed the problem. Thanks!

    For the search engines...

    Inspiron 1520 Windows 8 audio glitch skip driver solution sigmatel 92xx

  •  R153997