Inspiron 17R SE - Subwoofer doesn't work

Laptop

Laptop
Laptop computer Forums (Audio, General Hardware, Video)

Inspiron 17R SE - Subwoofer doesn't work

This question is not answered

I have recently received a brand new 17R SE. However the subwoofer doesn't appear to be working and the audio is very tinny.

I'm using the latest Dell Audio driver but to no avail.

Is this a known problem? Can anyone advise what I can do to make it work?

All Replies
  • Hi RandomReado,

    Please connect headphones with your system and check the sound. I will recommend you to uninstall and re install audio driver:

    • Click on 'Start' and right click on 'Computer'.
    • Click on 'Manage' and click on 'Device Manager'.
    • Expand 'sound, video and game controllers' and right click on each entry listed and click on 'uninstall'.
    • Once the driver is uninstalled, click on 'Start' and click on 'Control panel'.
    • Click on 'Programs and features' and look for the application by the name ‘Realtek’.
    • Right click on it and click on 'uninstall'.
    • Restart the system.
    • Click on the link: http://dell.to/Tg42Bs
    • Click on 'Download Now' and select 'Single file download'.
    • Click on 'Continue'.
    • Click on 'Save' and save the driver on the desktop.
    • Right click on the driver from the desktop and click on 'Run as administrator'.
    • Install the driver following the on screen instructions.
    • Restart the system and check if the issue is fixed.

    You can also update the BIOS in case the issue still persists:

    Note: Please save any unsaved data as your system will restart automatically after updating the BIOS. Disconnect all the external peripherals like printer, camera, scanner, external hard drive, flash drive etc. Also, the battery should be charged 10% or above.

    • Click on the link: http://dell.to/QNJmlC
    • Click on 'Download Now'.
    • Select 'Single-file Download' and click on 'Continue'.
    • Click on 'Run' and follow the on screen instructions.

    Keep me updated. Please reply for any further questions.

    Thanks and Regards,
    Vikram M
    #iworkfordell
    To know more about Dell’s products, services and drivers & downloads, please go to 
    http://dell.to/YBlak6

  • Hi Vikram.

    I forgot to mention a few things...

    Firstly when I received the system, I reinstalled it with a copy of Windows 7 Ultimate x64 (not the Dell image), installed all the latest drivers from the Dell website and Windows Updates.

    Secondly it's the IDT driver I'm using as this was the only available driver on the Dell website.

    Isn't there any way of testing the speakers individually? I know you can do this in Windows but there doesn't appear to be an option to test the subwoofer. In Control Panel, Sound, Playback Devices, I have right-clicked the IDT driver and gone to Configure Speakers. It only shows the left and right speaker - no subwoofer. From the Playback Devices screen, when I right-click the IDT driver and go to Properties, Enhancements, there's an enhancement in the list called "Bass Management" and when I go into the settings it actually says "Subwoofer: Not present".

    I'm running the latest BIOS - I made sure of that when I received the system and there's nothing in the BIOS to configure the onboard sound.

    Is it possible there is a hardware problem?

  • Actually im having a similiar problem on my Inspiron 17R SE.

    I installed Windows 8 from DVD and Ubuntu 12.10 as dual-boot on different partitions.
    Then I first of all installed all drivers in Windows 8 and my subwoofer was working perfectly!

    But after starting and configuring Ubuntu (subwoofers arent enabled, i think driver doesnt recognize them) and then rebooting into Windows 8 they are now turned off.

    It seems that Ubuntu changed some settings in the soundcard and Windows is not able to reconfigure those settings.
    Also complete deleting and reinstalling the drivers in Windows didnt changed anything. 

    I dont want to setup my whole system again only because of the subwoofers and i will have to use Ubuntu for studying so it seems that i have to go without my subwoofers on my Laptop.

    Any suggestions what i could do to fix this?

    Otherwise I hope that there will be a driver update from Dell which can handle this issue  soon!

     

  • I phoned Dell today and they're sending an engineer on Tuesday to replace the subwoofer... Bit drastic, but hey. Thing is they didn't do much in the way of troubleshooting when they remoted into my laptop.

    One thing I noticed on the Dell website there are 3 versions of the IDT driver. Two versions are the same, although released on different dates and one of the versions is newer than the other two, however when I install the newer driver, Windows complains the driver is corrupt! So it seems Dell have tried releasing a driver, but rather than fix the driver, they've re-released the old "initial" driver. Look under Previous Versions and you'll see what I mean.

  • Hi Randomreado,

    I am following up on behalf of Dell_Vikram_M. The drivers are tested and updated every now and then, on the Dell website. As the sub-woofer was not getting recognized, it may be an issue with the sub- woofer or a failure in the connections.

    Please keep me updated once the replacement is done. Do reply for any further help.

    Thanks & Regards,
    Dell_Abhishek_B
    #IworkforDell
    To learn more about Dell Products, Services, and Drivers, click Here

     

  • The engineer has been today, replaced the subwoofer and this has not fixed the problem. He is returning tomorrow to replace the motherboard - seems a bit extreme! I seriously doubt this will resolve the issue since everything else is working.

    The fact someone else is having the same problem with a different OS suggests this is a software issue. Perhaps not the audio driver, but maybe something relating to the BIOS? The engineer did say he thought it was BIOS related but the system is running the latest version! Any ideas?

  • I have managed to resolve the issue myself by using drivers for another laptop model altogether! I used the latest audio driver for the 14Z 5423 instead of the driver for the 17R SE.

    Also you have different audio driver versions all over the place on your website, which is really confusing, as follows:

    Inspiron 14Z: 6.10.0.6393,A01, 06/2012 (latest driver - subwoofer works)

    Inspiron 14Z: 6.10.0.6418,A00, 10/2012 (newer version number, older revision, but released recently? why isn't this the "latest"?)

    Inspiron 17R: 6.10.0.6388, A01, 10/2012 (latest driver, older version number then both drivers for the 14Z - subwoofer doesn't work)

    The Inspiron 17R actually has 3 driver versions, but the one with the later version number does not work and Windows returns with error code 52 in Device Manager when you install it.

    What a mess! Sort it out please Dell!

  • Hi Randomreado,

    Thank you for sharing the resolution. Glad to hear that you resolved the issue yourself; I really appreciate your technical expertise. I will certainly forward this matter to the Product Group team.

    Please reply if you have any further questions.

    Thanks & Regards,
    Dell_Abhishek_B
    #IworkforDell
    To learn more about Dell Products, Services, and Drivers, click Here

     

  • It's not really a fix... more of a workaround. That's what tech support said too.

    I noticed a driver update has been released today:

    www.dell.com/.../inspiron-17r-se-7720

    But when I try to download it, I get an error page!

    www.dell.com/.../DownloadError

  • Hi Randomreado,

    I apologize for the mix up on the website, this may have occured as there were a lot of driver updates.  The latest driver has been shared on the website and I was able to successfully download it. I have attached the driver, on this post. Please unzip > save the attachment >install it .

    Please share the results.

    Thank you for your feedback and do reply for any further questions. 

    4073.Audio_IDT_W7W8_A02_3F35Y-Setup_ZPE.zip

    Thanks & Regards,
    Dell_Abhishek_B
    #IworkforDell
    To learn more about Dell Products, Services, and Drivers, click Here

     

  • Little question: how can we test if subwoofer is working well?

  • Is there any chance to get this fixed?

    I tried at least five different drivers:  the latest one (released on 2013.02.08) that was available on the Dell drivers website for my laptop (filtered by service tag <ADMIN NOTE: Service tag removed per privacy policy> ), the previous one, the previous one, the three was mentioned by  RandomReado - no luck.

    It's ridiculous. One of the selling features of the 17R is the built-in subwoofer, which does not seem to work for many custormers. And no reaction from Dell. Nice.

  • Little question. You never considered that your problem is hardware rather than software?

  • Hi there, i personally use Ubuntu more than Windows due to my android related works and the subwoofer doesn't seem to be supported by the audio drivers. I googled around about this problem but this i think it's the closest thread about this thing available yet.

    I think the best way to do this would be for IDT to implement the drivers for Linux and make them available to download as proprietary drivers, the same way like nVidia for example.

    I look forward to hearing from....someone.

  • This helped me, but there is one drawback: subwoofer doesn't turn off when i plug in headphones: http://blog.sloniupl.eu/2013/03/13/dell-inspiron-7720-wbudowany-subwoofer-i-linux/