Vostro 3500 not working headphone in windows 7

Laptop

Laptop
Laptop computer Forums (Audio, General Hardware, Video)

Vostro 3500 not working headphone in windows 7

This question is not answered

i were install IDT Audio driver but when i plug head phone in the windows 7 64bit, that not sound hear through the head phone. i have dual OS(windows7 and Ubuntu). Headphone worked properly in the Ubuntu.

All Replies
  • Have you tried using System Restore? Type "System Restore" into the Start menu search box, and then, in the list of results, click System Restore. Try to find a date when the headphones were still working.

    I think a Microsoft automatic update has been messing up audio recently.

    Jim Coates -- senior forum member


  • i can't do that because. that loose my all data and installed software. i recently get windows update anyway thanks for your feed back.  

  • dduleep
    i can't do that because. that loose my all data and installed software.

    Hello. When you use System Restore you do NOT lose any data.  You are thinking of what happens when you restore the operating system. System Restore just undoes changes in the Windows registry.

    dduleep
    i recently get windows update anyway thanks for your feed back.

    I thought so. That might be what caused the problem.


    You can try re-installing the audio driver again.

    Jim Coates -- senior forum member


  • I were  System Restore and re-install audio drivers again but still have problem. i can't hear sound through head phone in windows 7

  • Try removing the IDT audio driver and using the native Windows audio driver instead. A couple of ways to do this:

    > Go to Device Manager and uninstall the IDT driver and select the option to delete the files. When done, reboot.

    OR

    > Go to Start>Control Panel>Uninstall a Program. Find the audio driver then right click on it and uninstall it. When you reboot the computer Windows will install its native audio driver. Check that it is installed by going to the Sounds properties. If it says "High Definition Audio Device" on any of the tabs then it is the native driver. If it says "IDT High Definition Audio Codec" then it is still an IDT driver, so repeat the procedure. (Windows will keep installing IDT drivers until all that have been downloaded are removed.)

    If that fixes it then there is a problem with the IDT driver and you may have to install a different version of the driver.

    Jim Coates -- senior forum member


  • I am having the same issue, and I have removed the IDT driver and the generic windows one is doing the same thing.  the internal speakers work just fine but no headphones.  I have not tried the system restore yet, and I am not sure when the last time it worked.  I will see if I can figure it out.  other than that if anyone has any other ideas I would love to hear it!!

  • and I tried the system restore and its not going back far enough since I have been screwing with the Drivers for most of the day...

  • Well my thinking was that if the same problem occurs with both the IDT and the native driver then it is probably a hardware issue, but the way to tell for sure is to test by running the audio tests in Dell Diagnostics with the headphones plugged in -- but not the PSA tests which just play system sounds that on some models will not play through headphones anyway.

    en.community.dell.com/.../19768710.aspx

    If you don't hear the audio during those test then it is definitely hardware. If you do hear it then the hardware is okay but probably an update has messed up the audio system.

    Jim Coates -- senior forum member


  • any idea how to figure rectify it if it is an update?  Like I said because I have been playing with the Drivers today all of my restore points it gives me are today and this has been going on for a week or 2 I just haven't been able to get to it till now.     I forgot to mention that I also have an Ubuntu partition and my headphones work fine over there.  I did the Diagnostic test and everything worked so I am at a loss...

  • If it works okay with Ubuntu then the basic jack hardware is okay. What I meant by an update is a Microsoft update if you have automatic updates enabled. I don't know how to determine if the problem is caused by an update except by eliminating other causes. If you restore the laptop to the original factory configuration and the jack works again I would blame an update, but if the functioning does not return then probably a problem with the sensing mechanism in the jack that triggers the switching circuitry when a plug is inserted. Does Ubuntu have its own audio driver? Probably Ubuntu does not utilize the switching circuitry. Dell Diagnostics audio tests cannot detect a problem with the switching mechanism because it uses its own non-Windows driver and does not use software switching, just mechanical.

    Jim Coates -- senior forum member


  • I believe that Ubuntu uses its own driver, I don't see anything the talks directly about the IDT one, but I will look more into the Windows update for sure.  thanks for you help mate

  • so after more digging, I found an old version of the driver and installed it an now it works again...  I really dislike computers!!!

  • Would you mind sharing the old driver that works? I also have the same problem :(