External Microphone on D610 doesn't work

Laptop

Laptop
Laptop computer Forums (Audio, General Hardware, Video)

External Microphone on D610 doesn't work

  • I have a Latitude D610 and after I found out that it does not have a build-in microphone anymore, I bought a Logitech headset with microphone.
     
    The problem is:  The speakers work, but the microphone does not.  (I of course tested the microphone with another computer, a D600, and it works fine)
     
    I have tried just about everything:
    - Device Manager: Everything is working properly
    - Audio Properties:  All settings ok (of course with the exception of the voice recording hardware test, which fails)
    - Volume Control for Recording: Everything is set ok, nothing is on mute, etc.
    - BIOS (A05): All settings are ok
     
    WHERE ELSE COULD THE PROBLEM BE FOR THE MICROPHONE NOT TO WORK (while the headphone is working fine) ???
    Can anyone help, please....
  • You must be kidding. Where did you find out that D610 does not have internal microphone?

    I just upgraded from D600, which had internal mic. Darn! And my D610 mic. does not work, darn again!

    I have just installed updated driver from Dell - R99254.EXE with not success.

    Now when I jiggle expernal mic. a little and keep it at certain position it seems to work (but not a permanent solution). Can't be happening ... a brand new laptop!!

  • Yes, you can read complaints about the D610 not having a mic all over the net.

    But you say, you got an external one to work ?  Did you connect it via USB or the normal plug on the left side on the machine ?

    Still the question remains for me how to get my headset mic to work ....

     

  • I can get external jack work, only by holding it half inserted. I have even tried with a mono plug; still the same thing. Looks like there is a pysical connector issue. However it is not easily accessible to take the jack apart
  • Hi All,

    I had exactly the same problem as Jochen K. I called DELL Support and they walk me through the web page to get a new sound driver and It worked!!!. Now I can use MSN, Skype, everything.

    Go to: support.dell.com -> Consumer (Home &Home Office) -> Product Support (drivers & downloads) -> Select your model Latitud D610 and search -> Select your OS and click on find downloads -> select Audii Driviers, you will find just one. So download it and when it finished run it and it will install the new driver. I restarted my computer despite it didn't ask though and then it worked!!!.

    I hope you can get your Mic to work. good luck.

     

  • to the man/woman above this post.....
    Yeah, tried your method. No workie! If someone else catches a wiff of the good luck your giving out, lemme know. Who knows it could spread.
  • After installing new driver; it took me a week or more (maybe number of reboots) - now external MIC works fine.
     
    Note: You have to open Volume control (detailed view) and make sure to un-check mute on microphone.
  • I have not ordered a microphone yet. What did you find that worked with your 610.
    Thanks, tcon
  • I am using simple KOSS headset and microphone.  But it does not matter. Just make sure it has stereo jacks of course (for both).

    A better option woul dbe to get a USB camera, which generally have internal microphone.
  • Hi Fatih,
     
    I update the driver last week on my D610 with R99254 as provided in dell.support.com and previous post. it still not work if you plug the external microphone jack in full. half-way still working.
     
    I use MS Windows XP Service Pack 2, what do you use?
     
    any more suggestion? I need it despearately.....
     
    Thanks folks.
    Amir
  • I was able to get mine to finally work.  Thought you guys might want to know what I did (and anyone else in the future), if you guys still weren't able to get an external mic going.

    First, I went to the support.dell.com website, entered my service tag, clicked to get into "All" drivers, clicked the Audio one (there's only one there for a Lat D610), and I downloaded & installed it.  Direct link:  www.dell.com/.../latitude-d610

    That downloaded R99254.  It didn't work.

    So I did some googling.  Found this one on Softpedia.com:

    drivers.softpedia.com/.../Dell-Latitude-D610-SIGMATEL-STAC-975X-AC97-Driver-A02-Download-69924.html

    That downloaded R90052.  It didn't work.

    The reason I'm including these links is because I'm not sure if it was the combination of having those drivers with what I did next did it, or if what I did worked on its own, but...

    I was in the middle of running the Hardware Test for my mic to see if the last driver download worked.  It got past the pre-check to where you do the speaking part, it didn't work to show any colors on the mic to represent audio.  Well I took the mic plug out, put it in halfway like it's been saying on some posts.  No dice.  I played with it a bit, put it in a bit more (about 3/4, I guess), while I was doing voice tests - finally it started registering my voice.  I inserted it fully and it still kept registering my voice!  I think there's some kind of activation that has to happen by putting the mic plug halfway (or 3/4) into the jack, and then fully after it has enough time to realize that "hey, there's a mic here!".  Stupid Dell...

    Hope this helps someone...

    -Tom