USB not detected by "Dell Backup and Recovery" application.

Disk Drives

Disk Drives
Disk Drives (Floppy, USB, HDD, CD/DVD/BD) discussion

USB not detected by "Dell Backup and Recovery" application.

This question is not answered


                         I have Dell Inspiron 15R (5520), I need to create a factory backup using Dell Backup and Recovery application, but the USB( Transcend 16GB )  inserted is not detected by the application, instead the clock in the application just runs and runs. 

                         Please donot tell me to use another USB or with DVDs and to update application as I have unlimited internet service and my PC is up to date. I have tried with many USB's and got the same problem. Give me a solution to create a factory backup using the USB that I mentioned above which is latest.

                        Please give me a solution if Dell really cares its customers.

All Replies
  • Hi Anandrnaik,

    Please insert your flash drive into a USB port and tell me if you see it appear as a removable drive in Windows Explorer.

  • Yes it surely does. 

    Waiting for a solution.

  • Please keep in mind that I'm a user like you. Not a Dell employee. So I can't make promises about whether you'll arrive at a solution.

    Can you post a screen shot of the available drives in the recovery utility?

  • I don't know if this will help as it's based on a sample of one, but here is my experience.  I received an Inspiron 660s loaded with Windows 8 - 64 bit.  After going through the registration process, I inserted a PNY 32 GB USB memory key cause it was available.  I started the back-up application and reached the screen to back up the factory recovery image.  After clicking on the execute button, I get the message to select the desired memory stick and click start.  The only trouble is, all I see is a clock symbol clicking away the time, and the list of available memory sticks never appears.

    After considerable time has passed, I click the cancel button and restart the computer.  This time I start the back up application and get all the way to the screen that is supposed to allow selection of the desired memory stick before inserting the USB memory key.  I figured that perhaps the back-up application is having trouble sensing the presence of the memory stick, and that maybe the signal that Windows provides after detecting a memory key will shock the back-up application into working.  Unfortunately, no luck.

    Once more, I cancel, extract the memory key, and restart the back-up application.  I go all the way to the point of selecting the desired memory stick as before, but this time I insert the memory key into a port I have yet to use.  While the clock is going, Windows detects the new location, and the memory stick appears on the window.  I click it, click the start button, and the back-up application successfully makes the factory back-up.

    I can't be certain that the procedure I used is what kicked the back-up program into working.  I may have simply gotten lucky.  Just for safety's sake, each time I extracted the memory stick I remembered to click the icon for safely removing hardware.  I don't think that is supposed to matter anymore, but I'm sort of old fashioned.

    Dell Forum member since 2005

  • Hi Jackshack,

    I also did some playing around with this. I tried a few flash drives of various capacities and none of them worked--same problem with the spinning clock. I wasn't sure if it was due to insufficient capacity, so I clicked the recordable disc option to check. The recovery utility found my DVD-RW drive right away, and I was able to determine that I needed an 8GB flash drive. I hit cancel, went back and selected USB drive and it found my flash drive.

  • It is irritating that a work-around must be used to get the back-up program to work, but at least it is possible.  Perhaps a version will eventually be released that doesn't need to be kicked to get it to recognize the USB drive.

    Dell Forum member since 2005

  • We had the same problem with XPS 12-9Q33 with the latest BIOS (A3).

    We tried different USB keys, different timing of key insertion, disabling WiFi and Bluetooth, but nothing helped.

    What finally helped was BIOS setting (press F2 on startup) Advanced -> USB Emulation. It was set to Enabled and we changed it to Disabled. Backup utility was now able to find the USB drive.

    - Mitja

  • That's an old topic but I will post an update just in case someone bumps into this problem again. Thankfully this discussion was very helpful.

    In my case: brand new Vostro 5470 (maybe it was launched on Nov '13). Dell Backkup and Recovery software wasn't recognizing a 16GB usb drive.

    Explorer was showing it up. After all the initial setup I was anxious to create a recovery disk. Same problem as above, the clock was ticking until it hit a timeout and no external drive was found. The only thing I needed to do was rebooting the computer just once.