Forums

Desktop

Desktop
Desktop computer Forums (Audio, General Hardware, Video)

Dell XPS 8700 - Secondary SATA Hard Drives Not Showing Up

This question is answered

I tried installing two additional hard drives on my brand new XPS 8700 . The machine came with the primary drive attached to SATA 0 and the DVD drive attached to SATA 1. When I installed the two additional hard drives, I put them in SATA ports 2 & 3. The hard drives didn't appear in Windows (8.1), nor in the BIOS. I played around with SATA ports 2 & 4, and 3 & 4. The hard drives weren't recognized. When I looked in Disk Management, they weren't there. As a last resort, I unplugged the SATA cable from the DVD drive, and plugged that cable into one of the secondary hard drives (which was now attached to SATA port 1), and used that Drive's cable to plug the DVD drive in SATA port 2. When I booted up my computer, all of the drives became visible. I'm not sure why. The SATA cables that I used came from a 5 year old computer (as did the hard drives). Was this a problem with the cables, or is it a SATA port problem? Does the first secondary drive need to go into SATA port 1?


I searched the forum and could only find one similar problem (http://en.community.dell.com/support-forums/desktop/f/3514/t/19520798.aspx) . That individual ended up returning his computer.

Verified Answer
  • alexsyseng,

    you are mostly right. i experienced this same problem as well but i already had the a06 bios. the problem is with the uefi feature of the bios. its ment to be more secure but causes problems when adding drives. i tried your suggestion of switching the secure boot options but that did not work for me. i found the solution by accident when i switched from uefi to legacy boot so that i could use my discpart cd to secure erase my ssd.

    so here is the solution, everytime you add a drive you will have to switch the bios to legacy mode then switch back to uefi mode. if your computer came with windows 8 then more than likely your bios is set to uefi. when you switch the bios to legacy your computer will error and tell you that it did not find any boot drives. no worries, switch it back to uefi, reboot, and now your system will boot correctly and all your drives will be visible in windows and disk management. no need to replace your motherboard. unfortunately i spent two hours with tech support and they did not know this either.

All Replies
  • Hi DaveGee281,

    I have heard anything similar to your problem. In older systems, we would recommend hard drives connected to ports 0, 1 and optical drives in other ports, but the 8700 has all SATA III ports so I wouldn't think it makes any difference. But apparently it does.

  • I had a similar problem with the same machine.  I installed a brand new Intel 240GB 530 series SSD in SATA port 2 which showed up only in BIOS and nowhere else. Intel support was no help in solving the problem, recommending I try installing it in another machine.  I tried moving the optical drive to #2 and SSD to #1 with no change. It would always appear in BIOS. I wanted to clone the HDD (with 50GB of data on it) to the SSD but could not get the drive recognized.  I finally gave up and did a clean install of windows 8 on the SSD, which worked. I'm now working on getting all the drivers installed correctly. I hope you can find a solution.

    George

  • Any help would be appreciated. I now have 4 of the SATA ports functioning. The C: drive is in Port 0. Two hard drives are in Ports 1 & 3. The DVD drive is in Port 2. I can't seem to get Port 5 to work. If I move one of the hard drives to port 2, and the DVD drive to either port 4 or port 5, both the DVD drive and the moved hard drive disappear. The drives do appear in the BIOS. I intend to upgrade to an SSD sometime this week.

  • Moving the drives around may cause a drive letter conflict. But even if they do, you should still see all connected drives in disk management, even those not assigned a drive letter.

  • I was on the phone with level 2 tech support for 3.5 hours this afternoon. The guy had me switching hard drives and the DVD player from 1 SATA port to another. SATA 3 didn't work under any situation. In fact, when a drive or DVD player was plugged into that port, most of the other drives disappeared.

    Tech support said that I needed a new motherboard. I find it weird that all of the SATA ports show that they are occupied in the BIOS (strange that that the BIOS  uses a numbering system that goes from 1 to 5, while Windows numbers the ports from 0 to 4). I suspect that it's a driver issue. Regardless, a technician will be coming by this week to install a new MB.

  • It looks like this is BIOS refresh or BIOS/OS integration issue.

    I was able to workaround it by installing a new BIOS version as well as changing Secure Boot settings.

    System configuration: DELL XPS 8700, CPU i7-4770, RAM 16GB, HDD 1x250GB (OS), 3x 2TB, W8.1, BIOS A04

    Originally I had one 2TB HDD that came with the system from DELL. I have decided to separate OS from DATA and added another 250GB HDD for the OS. I have migrated the OS to 250GB HDD and cleanup the original 2TB hard drive for DATA. I don't remember what BIOS level did I have at that time, but I didn't run into any issue with doing this. After upgrading W8 to W8.1, I have upgraded the BIOS to version A04 as well.

    I have identified the issue after adding 2 additional 2TB hard drives to the system in January 2014. Both of them didn't show up in the Windows 8.1, but appeared in the BIOS. I have disconnected the recognizable 2TB drive, but left the OS drive and connected only one of the drives that has not been recognized and boot up the system. I didn't change any SATA ports. The new drive didn't show up under the Device Manager in the OS. I have checked DELL WEB site for BIOS updates and figured out that DELL has posted newer BIOS version A06. After the BIOS update and the system reboot the previously not recognizable new hard drive has showed up. I thought that issue is related to the specific BIOS version, shutdown the system and added the other two hard drives. One of them has been recognized before and one has never been recognized by the system. Surprisingly, after reboot the newly connected drives didn't show up. From this point I understood that this is sort of BIOS/OS refresh issue. I went back to the BIOS and changed the Secure Boot settings from Disabled to Enabled. After the system restart all hard drives have showed up in the system.

  • alexsyseng,

    you are mostly right. i experienced this same problem as well but i already had the a06 bios. the problem is with the uefi feature of the bios. its ment to be more secure but causes problems when adding drives. i tried your suggestion of switching the secure boot options but that did not work for me. i found the solution by accident when i switched from uefi to legacy boot so that i could use my discpart cd to secure erase my ssd.

    so here is the solution, everytime you add a drive you will have to switch the bios to legacy mode then switch back to uefi mode. if your computer came with windows 8 then more than likely your bios is set to uefi. when you switch the bios to legacy your computer will error and tell you that it did not find any boot drives. no worries, switch it back to uefi, reboot, and now your system will boot correctly and all your drives will be visible in windows and disk management. no need to replace your motherboard. unfortunately i spent two hours with tech support and they did not know this either.

  • davegee281,

    2 things. all sata cables are the same regardless if they are labeled sata 1, 2, or 3. that is just a marketing gimmick to make you go out and buy new cables. your old ones are fine to use unless they are defective. second thing, all sata ports on the xps 8700 are sata 3 and it does not matter where you install your optical, hard drives, or ssds. not sure why they decided to make the ports different colors. maybe just to confuse us.

  • Alexsyseng

    Where did you find the option to change uefi to legacy? I looked but could not find the right screen in the bios.

    Thanks for the help.

  • On DELL XPS8700. Press F2 during the system boot to get to the BIOS screen. From the Boot TAB in the BIOS, select Boot Mode field. Press +/- to alternate the setting between UEFI and Legacy. Press F10 to save the change. Best Regards,
  • I confirmed that this worked on my XPS 8700. Added an 1 TB WD10EZEX and could see it in the BIOS, but not in the Win 8.1 Disk Management. Switched the bios to legacy mode, and got a disk boot startup error / message. Switched it back to UEFI mode and rebooted. Went back into Disk Management and behold, it recognized and asked to initialize the new disk. Thank you, for this post, it helped me hope it helps others.
  • Awesome trick !!! I just got my SE, you save me a lot of time!! after change to legacy asked for an Intel confirmation during booting, just reboot again and switched back to uefi, all my drives are show in windows 8.1 !! thanks a lot for this !
  • I have A7.  To get change to legacy I had to use F12 and temporarily make the change.  Afterwards I changed it back and my problem was solved too.  Thanks everyone for your help.  

  • Recent XPS8700 out of the box. Top configuration: 256 SSD + 3TB HD + DVD , 32GB memory ... BIOS A07. Trying to conect the DATA HD of my old computer (2TD Western Digital Green) did not showed up in Win8. Same problem.

    Working at BIOS level, any device conected to the 5 SATA slots are recognized by BIOS, but when boot ... did not showed up. Even at Disk Administartion level.

    The problem is the SECURE BOOT setting in the BIOS Boot Level .... talking with Dell Help desk ... with BIOS A07 did two changes in the Boot Tab of the BIOS.

    1 - Change Secure Boot Mode to Custom (was Standard)

    2 - Change Secure Boot to Disabled (was enabled)

    Press F10 to save & exit.

    No necessary to change to Legacy mode (that it´s posible now, before without those changes was blocked)

    Reboot computer and boot Win8 ... now it´s installing devices and recognized by the system.


    Hope this help.


    Juan