USB Devices Randomly Connect and Disconnect on Dell XPS 8500

Desktop

Desktop
Desktop computer Hardware and Software discussion

USB Devices Randomly Connect and Disconnect on Dell XPS 8500

This question is not answered

Earlier this month I had a 3TB Seagate GoFlex external drive die during a backup.  I was unable to recover any of the data on the drive.  However, I was able to restore data from a 3 week old backup onto a 4TB Seagate Backup Plus Desktop external drive.  However, the brand new 4TB Seagate Backup Plus Desktop external drive is randomly disconnecting and reconnecting itself to the computer.

The drive will work fine at first but then after around 30 minutes to 2 hours I hear a sound as if a new USB device is being connected.  I see this in the taskbar at the bottom also.  Anything I was viewing that runs off of the external hard drive such as a video will stop and the drive will come back on as recognized.  I don't think I'll be able to complete a backup because it usually takes at least 5 hours and if it gets interrupted like that, the backup will fail.

I have tried connecting the external drive to multiple USB 3.0 ports and they all result in the random disconnect/reconnect issue.  I also multiple USB 3.0 cords and different AC adapters to no avail.  I also tried a new 3 TB Seagate Backup Plus drive.  I managed to copy all of the data from the 4TB drive onto a brand new 3TB drive and thought that things would be fine.  In less than a day later, the new 3TB is experiencing the random disconnect/reconnect issue as well.

I have tried troubleshooting with Seagate Dashboard and SeaTools for Windows.  They report that the external drives are both in working condition.  I do not know what to do at this point.  I'm not sure if it's an issue with my Dell XPS 8500 or what.  I just never had this issue until my previous 3TB external drive died (it worked for over 6 months without any issues) during a backup.  I cannot have hard drives randomly disconnecting and reconnecting because I will not be able to do a full backup.  Please let me know what to do to resolve this issue.

All Replies
  • I have exactly the same problem on an XPS One 2710 Touch with Windows 8 Pro. Tech support has been of no help-their answer was to re install the operating system. That didn't help and neither did upgrading to Windows 8.1 Pro. I have tried updating USB drivers but nothing seems to work. I did find that if I use Device Manager to disable the device and the related USB controller, relocate the cable to a different USB port  and then enable the controller--the drive will come back on-line. Is there a fix for this problem?

  • Have you checked the Power Management tab for the USB root hubs to make sure the box "Allow PC to turn off this device..." is NOT checked?

    Disconnect all USB devices, except mouse and keyboard. Then open Device Manager and expand list under USB. Double-click a root hub and then click its Power Management tab. Uncheck that box, click OK back to main Device Manager screen and repeat for all root hubs, and then reboot. See if that solves the problem.

    If this answers your question, please click  Yes  

    Ron

    Forum Member since 2004

    I am NOT a Dell employee

  • I have the same problem with Windows 8.1  External Seagate drive.  The Intel 3.0 ports are using a Microsoft driver.  There were no USB 3.0 bus drivers for Windows 8 released by Intel.  I unchecked the power management box in device manager.  I made sure there were no power options that could also cause this.  My external drive still randomly reconnects after 20 minutes to 2 hours.  I only have a problem on the front 3.0 USB ports.  I have to resort to plugging it in to my USB 2.0 rear ports. 

     

    I think the problem is with the Microsoft 3.0 USB driver.  I have uninstalled and reinstalled the driver already as well as instructed by Seagate.

  • I too am having this issue with my new (this month) Dell One 2330 (all-in-one). My Seagate expansion drive will be usable when I boot up, but after a while it loses the connection. If I unplug-replug, I get a message saying the USB device cannot be recognized or has malfunctioned. It works fine at the next boot though.

    I thought it might be a sleep/power issue. I unchecked the option "Allow the computer to turn off this device to save power", for each USB Root Hub in Device Manager. I also one one power-related option in BIOS setup, which I also disabled. HOWEVER, I've set the system to never sleep when idle (only dim the display), and the problem still happens.

    The other devices I have plugged into USB 3.0 ports (scanner, printer, mouse/keyboard) do not exhibit this problem. The scanner is only powered up when needed, but the printer and mouse/keyboard are always on.

    As far as I can tell, I have the most recent drivers for the Seagate drive and USB ports. Running Windows 8.1 now, but had the same behavior with 8.0.

    Any advice appreciated!

  • I'm having the exact same problems described above with my xps 8500 usb 3.0 ports and my seagate backup plus 4TB external drive. Looking for advice...

  • This is not the easiest thing to do but it's not the hardest and it works (for me).

    http://blogs.msdn.com/b/usbcoreblog/archive/2013/11/01/help-after-installing-windows-8-1-my-usb-drive-disappears-or-file-transfers-stop-unexpectedly-r-a-post-title.aspx

    The instructions are pretty straight-forward.  I followed the steps and edited the registry as directed.  I no longer have spinning down drives.

    I hope it works for everyone on here too!

    -t.k.

    BTW: All of those posts that talk about checking Power Management settings did ABSOLUTELY NOTHING.  Basically any option you come across anywhere that LOOKS like it would either control or affect this behavior: IT DOESN'T.  Well, at least not in anything that I tried to do. Smile

  • Sorry for the delay in responding, life got in the way. Anyhow, this resolved my problem. Yesterday I did a Dell update to the chip set and my external drive dropped off-line today. I went back and check and one of the hubs had been reset to "Allow PC to turn..." I made the change and the problem has been solved one again.

    Many thanks,

    ron

  • I have the same symptoms as described with my Dell XPS and Seagate 3TB and 4 TB drives and I have tried all suggestions including the registry hack, but I still have the issues. It is so annoying.
  • StephenCrump
    I have the same symptoms as described with my Dell XPS and Seagate 3TB and 4 TB drives and I have tried all suggestions including the registry hack, but I still have the issues. It is so annoying.
    If your Seagate USB drives came with Seagate's tools utility, launch that with the drives connected and change the settings for both for time to shut off the drive to "never" (or at least to a much longer time than currently set). See if that solves the problem.

    If this answers your question, please click  Yes  

    Ron

    Forum Member since 2004

    I am NOT a Dell employee

  • I'm pretty sure that I looked at using the Seagate utilities, but they said they would not run on my Windows 8.1. But I will have another look. I get the same issue with a pen drive when I plug it into my USB 3.0 hub. 

  • Look for updated version of the utilities on Seagate site - but I don't know if one exists. Otherwise, try running it in Compatibility Mode for an earlier version of Windows.

    And you're sure all the "Allow PC to turn off this device..." boxes are unchecked for every USB root hub in Device Manager. Note: You may have to disconnect all USB devices (except mouse and keyboard) to make those tabs visible.

    When the drive has disappeared, is that after you wake the PC from sleep or hibernation?

    Try turning Hybrid Sleep off on the Power Plan>Advanced Settings screen.

    If this answers your question, please click  Yes  

    Ron

    Forum Member since 2004

    I am NOT a Dell employee

  • I cannot get Seagate's drive settings utility to detect my 4TB drive. 

    I had UNticked all of those boxes, but one of them had become ticked again!!!

    I have now disabled Hybrid Sleep. See how that goes. Only 1 of 4 external USB drives physically connected at the moment. This I use for File History... when the PC can see it!

    thanks

  • This worked for me Big Smile

  • Other possibility is that the 4T drive is trying to draw too much power from the USB hub so PC is ignoring it.

    My 1.5T Seagate USB drive needs a USB Y-connector to be seen. It connects drive to 2 USB ports on PC. One port provides data and power, the other one provides additional power.

    So you might try a Y-cable. Or alternatively, an external USB hub that has its own power brick. Connect brick to the wall and the hub to the PC. Connect those power hungry devices through the powered hub.

    If this answers your question, please click  Yes  

    Ron

    Forum Member since 2004

    I am NOT a Dell employee

  •      That's an interesting point you bring up RoHe. Until lately ALL 3.5 HDD's required a 12v core to operate. NOW most are 5v core and are USB friendly. I might add to RoHe's remark.

    RoHe
    possibility is that the 4T drive is trying to draw too much power from the USB hub so PC is ignoring it.

         that you would be well advised to check that your Drive doesn't require a "High Power USB Port" implying the availability of a 12v core voltage across that port. HDD's are inductive electrical load and only pull what they need. Once that load exceeds available power rated for a port....you can guess where this is headed right? You'll also want to make sure that if there is a 12v requirement on your big Desktop External that you locate a High Power USB port on your computer or plug the Drive into a supply (some externals...usually big ones...come with dedicated power supply / adapter...other's just assume you have 12v available.

    Dell™ Community Forum since 2013

    Not employed by Dell™