Intel Chipset Driver successfully installed yet no change in driver version?


Desktop computer Forums (Audio, General Hardware, Video)

Intel Chipset Driver successfully installed yet no change in driver version?

This question is not answered



I downloaded the above update package file which was listed for my service tag as a driver update.  Everything appeared to have gone as desired.  It went through the process and said it was completed successfully.  I read the long text file it opened upon completion which, as best as I could understand, said it updated nine devices (listed below).  Except the driver versions for those devices, in the device manager, list the same ones it did before installing the update.

So what do I need to do to in order for the new drivers to be installed if the installer doesn't actually do it.  I did reboot after the install even though it didn't say anything about needing to.  No difference upon restart.

Intel(R) 7 Series/C216 Chipset Family USB Enhanced Host Controller

Intel(R) 7 Series/C216 Chipset Family USB Enhanced Host Controller

Intel(R) 7 Series/C216 Chipset Family PCI Express Root Port 1

Intel(R) 7 Series/C216 Chipset Family PCI Express Root Port 2

Intel(R) 7 Series/C216 Chipset Family PCI Express Root Port 6

Intel(R) 7 Series/C216 Chipset Family SMBus Host Controller

Intel(R) B75 Express Chipset LPC Controller

Xeon(R) processor E3-1200 v2/3rd Gen Core processor DRAM Controller

Xeon(R) processor E3-1200 v2/3rd Gen Core processor PCI Express Root Port

Thank you.

All Replies
  • I suggest going to Intel's download site and checking your chipset drivers using their online chipset software update utility.

  • I went to the Intel site to do so but that utility said it required Java to be installed.  I'd rather not have that on my computer.  

    Additionally, the Intel site mentioned downloading them from ones manufacturer as the ones they offered were the generic drivers where as the manufacturer may have modified them for their customers so that I would like to continue to explore whether or not that is an option fully.

    The ones Dell have listed for my service tag list the driver version as  The driver versions listed for those nine devices, listed in the first post, in my device manager list those as or currently.  Those seem to correspond to the previous driver versions on that linked Intel Chipset Driver on my Dell driver page as that lists the previous version as

    So downloading and installing the Intel Chipset Driver listed for my service tag from Dell should have updated those to shouldn't it?  The update package file says it performs "specific validation criteria are met before performing the update" so that I am guessing that if it said it was successful that it verified it was applicable and was supposed to work.  

    I tried a couple of times now with the same result.  Everything appears to work as it should but the driver versions don't actually seem to have been updated.  

    It seems pretty straight forward so I'm not sure what i am missing.  It lists the drivers available for my specific service tag.  I verify the correct OS is selected.  It shows 6 drivers that are newer than what I had installed when my PC was built.  I downloaded the Intel Chipset Driver update package which lists it as being version which is newer than the driver versions or that are currently installed.  I run that.  It says successful but no change in driver versions.

    Any more ideas?

  • I tried downloading the hard drive file option this time, I was using the Update Package file previously, just in case one worked but not the other.  Same result with the hard drive file.

    This is just a theory, without the knowledge to know whether or not this might even be a possibility, but I noticed the files it extracted contained separate Windows 7 and 8 folders (since it is applicable to both OS).  The Windows 7 folder contained a bunch of files but the Windows 8 only contained 2.  

    Any chance this whole installer saying the update is successful yet the driver versions not, seemingly, being updated could be caused by the Dell download file not actually containing the necessary files for Windows 8 users by accident?  Might that explain the installer saying everything was successful and the drivers not actually being updated due to it missing files it needs?

    If that is a possibility, would anyone mind verifying?  One could just download the Update Package file from (use the Update Package file rather than the hard drive file as the later opens the setup file after extracting - though easily cancelled).  When you run the file it will ask if you want to install or just extract the files to a file of your choosing.  Extract the files and see if the theory makes any sense or not and delete them when done.  

  • userh57dh4
    I went to the Intel site to do so but that utility said it required Java to be installed.  I'd rather not have that on my computer.  

    Were you using Internet Explorer? My understanding is that IE will install an ActiveX control, while other browsers will require a Java application.

    If your 660 is working properly and all devices have properly functioning drivers, there may be no need to update the drivers.

  • I was using Firefox so that explains that.  I didn't know that IE may be different so thank you.

    My PC is working fine.  If it might be possible to figure this out, I'll give it another go.  If not, I guess I will avoid updating drivers in the future.

    Do you have an opinion on whether my attempts using the Dell driver files for the Intel Chipset Driver should have worked and reflect the versions in the device manager?  And if it should have, is there something else going on or could it possibly be an erroneous file(s) from Dell?

    One last question, would any harm have been caused by what happened?  Everything seems okay but I also have no idea what that driver installer might have done.

    Thank you kindly for your assistance.

  • It may be the 660 already has the latest drivers installed and that's why the driver versions stay the same. I like to use the Intel utility because it will indicate whether the drivers are current or newer versions are available. To use IE for the chipset utility, you'll need to install an ActiveX control, but note that the control is safe.

    As for physical harm, rest assured that the driver installer doesn't harm your hardware.

  • I was more wondering about added software bloat/conflicts rather than anything hardware related.  

    If mine had the same driver version, seems like it would reflect rather than  Dell listing the previous versions of that driver as and offering the drivers seems like it would suggest there is a more recent version in comparison to what is currently installed.

    I'll consider giving the Intel Utility a shot using IE when I get a chance.

    Thank you for your time.

  • Still just thinking aloud but figured I'd share one more thing in case it might help anyone on the chance there is an issue with the Dell file(s).

    I checked the log file it leaves behind and noticed a handful of instances of the following.  Again, no idea if this has much to do about nothing but just in case it might be at all useful.

    !!!         ERROR 0xE0000102: SetupFindFirstLine generated an unexpected error. skipping inf

    Perhaps nothing as the installer said successful each time.  It just seems odd that Dell lists the previous versions of that driver, 9.3.0. series, that match the version I have installed yet the newer version file,, installs saying successful yet doesn't reflect the more recent driver version.  

    I was able to just use IE and try the Intel Utility again but my settings must block it as it said it couldn't be installed with my current settings.  Unless by chance the issue does end up being with the Dell file(s), I'll take that as time to give up. :-)

    Thanks again rdunnill.  Hope you didn't mind my thinking aloud also.  Helps me learn and I am hoping it may provide some clues on the chance someone can confirm or refute the issue being with the actual files.

  • You're welcome. As for the ActiveX control, did you get a pale yellow bar at the top asking if you wanted to allow the installation of the control? It can be easy to miss.

  • No.  It didn't bring up that typical block bar at the top.  Within the IE page itself it showed a moving bar, if memory serves, that eventually changed to text saying something along the lines.. hang on.  Let me try again quickly right now in order to be accurate.

    I go to the utility page.  Click the "check your system for latest updates" which then turns into a moving loading bar.  After about a minute it bring ups an actual pop up type box, saying "Message from webpage.  The Intel Driver Utility installation failed.  Possible web browser compatibility, firewall or installation issue detected.  Click OK to troubleshoot issue."

    No worries though.  Originally I thought this whole thing might be something simple.

  • Hmm ... I think I got that error, too. You may need to update IE.

    This is the latest version of Intel's chipset software:

  • Is your firewall or antiviral suite blocking ActiveX or the update?

    Do you have Java (not javascript) installed? Without Java installed and running, you can't install the Intel chipset utility, but I think rdunnill already said that..

    If this answers your question, please click  Yes  


    Forum Member since 2004

    I am NOT a Dell employee

  • Firefox uses a Java applet, while IE uses an ActiveX control.

    I ran into this issue last year. I forget what the resolution was, but I am thinking it had to do with installing Windows updates.

  • I tried to run the Intel chipset updater after downloading with IE8 and it came back saying I needed to have Java running, which I don't have on this system.

    If this answers your question, please click  Yes  


    Forum Member since 2004

    I am NOT a Dell employee

  • The IE issue with the Intel Chipset Utility being blocked ended up being nothing more than my having disabled ActiveX scripting but forgetting all about it.  Other than keeping IE up to date, I haven't used IE in years so it completely escaped me.

    Thanks for the direct Intel link rdunnill.  That was the first I had been able to find the release notes.  And after all of this, I think I am just going to end up passing on updating it.  There doesn't appear to be anything worthwhile that would apply to my system in that series.  

    Perhaps that solves most, if not all, of the mystery.  That that series of drivers just didn't contain anything that my system would have been all that noticeable on after installing.  With Dell listing it as recommended and the later driver version, I guess I just expected it would actually reflect the later driver versions in those devices.  Perhaps it just doesn't as it sounds like the vast majority of that new driver series is branding and things that don't apply specifically to my setup.  Occam's razor.

    Think I might just learn to leave well enough alone from now on.  I've never owned a pre-built PC before so I think blindly trusting the updated drivers section listed for my service tag might need to come with a little more apprehension from now on.  I'm just hoping the remnants the installer left behind, as the installer unfortunately did not do a good job performing cleanup when it was completed (they never do), won't add any bloat or future issues to the registry.

    Thanks again for everything.