Forums

Desktop

Desktop
Desktop computer Forums (Audio, General Hardware, Video)

Trying to add a new 256 GB mSata SSD on XPS 8500 Win 8

This question is not answered

Hi all

I just followed instructions on how to add a mSata SSD to an XPS 8500 but I'm having issues.  The instructions on another post on this community said to install the mSata SSD and remove the cables of the existing HDD (2TB) and then re-boot using the backup/recovery disk using a USB. The problem is that when going through the recovery disk process I'm told that it will not work on the new drive as it needs to be 1863 GB in size.  My new mSata SSD is only 256 GB in size.  When I created the backup on the USB drive it only used up 12 GB of space so I'm not sure why it is asking me to provide a disk that is 1863 GB in size.  If it helps, I have used up 362 GB on my original 2 TB hard drive.

Any help on this matter would be greatly appreciated.

Jeremy

All Replies
  • I followed those same instructions and had no problem at all using the directions from the post.  I went one step further and removed the sata cables from both of my DVD drives, in addition to the original HDD.  After installing the mSata, I rebooted and went into the BIOS and ensured that it recognized the mSata card, that it was setup as the primary HDD.  I then went into the recovery screen and installed the OS from a USB drive.  It went slow at the beginning as it formatted the mSata and the rest went very quickly.  After rebooting and ensuring all was working well, I then plugged in the original HDD and rebooted.  I ended up breaking it up into two partitions - one for data and one for old backups.  Finally, I reconnected my DVD drives and ensured that they were working, too. 

    What took me the most work was my desire to put the OS and other software on the mSata and store all of my files on the data drive.  I had to find some good tips on the web on how to best do that.  I also looked up some articles on tuning the SSD drive and ensuring that auto-defrag was turned off.

    Overall, I saw impressive improvements in boot time and peformance, but not the lightening times some have advertised.

  • Thanks for your response Koeven.  I tried following the same instructions again but with your added extra step of disconnecting the  DVD drive but unfortunately got the same result.  "Your hard drive size is not supported for this process.  Please use a hard drive at least 1863 GB in size".  It can see the hard drive in the bios under the drives list but when back in Windows 8 in disk management it shows the mSata SSD as Disk 1 but "238.47 GB Unallocated".  Disk 0 is the original 2TB HDD showing the various partitions.  I'm wondering if there is something that I need to do in disk management.  In windows explorer I can still only see the original HDD as the C drive, not the new SSD drive.

  • I have the exact same issue.  searched in google no luck.

    My HDD size is 2 TB as well.  Looks like when you take the system backup, it takes the size of C Drive.  You can't shrink it either to the size of SSD and Disk Mgmt does'nt let me do so.  Best I can shrink is 950 GB and will not help.  Also Dell Backup/Recovery will let you take backup only once..  You need to pay to upgrade to take more system backups.  I am stuck.  Anyone out there who can help??  If I can't find a hit in Google, most likely it is a dead end :-(

    Ram

  • I also tried reducing the partition size in disk mgmt but like you, could only get it to around 950 GB and got the same error message about the drive size not being big enough when trying to recover from the Dell backup.  Nor could I find anything on Google but it seems that others in this community had no problem at all.  I also contacted Dell to get them to send me the installation disk for Win 8 - it arrived today so I'm just going to do a new install on the 256 GB SSD, with the 2 TB drive disconnected.

    Jeremy

  • Looks like the new windows 8 system backup somehow stored the actual size of C: while taking backup and expects the new drive you are installing to be the same size.  Does'nt make sense and looks like a bug to me

    Ram

  • I meant to say that Dell system backup/recovery app stores the actual size of C: in the system backup

  • Update

    Called Dell and looks like they are not aware of this problem that doing a system backup from 2 TB drive and trying to restore on 256 GB mSata.  But installing windows 8 from dvd should work and they will send one to me.

    Asked the support person to check on this issue to see whether it is a bug in Dell backup/recovery software.

    Looks like the Dell Tech support person was very knowledgeable and was able to quickly answer all my questions on BIOS, boot loader, Changing boot drives etc etc.  

    Ram

  • So the new disk arrived from Dell with Windows 8, I go to do a clean install on the SSD, without the HDD connected, and I get the message "The product key entered does not match any of the Windows images available for installation.  Enter a different product key".  One you select "OK", thinking there will be an opportunity to enter a different product key, it just goes back to the set up screen.  Tried to google this problem but couldn't find any real solution.  I'm starting to think it was a bad idea getting an SSD after buying the computer.  I thought that it would be smooth sailing after reading that so many others had done it without any issues.

    If anyone knows how to fix this problem I would be very grateful.

    Jeremy

  • Dell shipped winodws 8 CD and my installation went smooth.  I disconnected the HDD to start with before I started the OS install on SDD.   Then I reconnected the HDD.  No problem.  Used a cross over cable and copied ~1 TB of data from my old computer to new..  Installed all the apps on SDD.  Now I have windows 8 and all the APPS on 256 GB SSD and all my data on 2 TB internal HDD

    So far so good but There is no Dell backup recovery app with the clean install and also my disk management is not working and it is giving not able to connect to virtual disk service..  Need to find out what is going on..  But I am up and running with the new machine

    Ram

  • I am still having issues here once in a while.

    When the machine hangs sometimes,  I have to reset it (no other go) and msata drive disappears as a boot device and

    I can't see msata in the BIOS.  I have to boot windows 8 from HDD (setup for dual boot) and then if I reboot, I can

    see msata.  Then I have to change the boot order.  This is very annoying since windows 8 hangs once in 2 days when I am in photoshop..

    Ram

  • Update: Dell sent the wrong disk after several calls with them.  They sent another Win 8 installation disk but further problems lay ahead.  The also told me that you can't use a recovery back up for a large HDD and then use it as a recovery disk on a smaller disk drive.  This must be a bug as the size of the back up disk for me was only 12 GB.

    With my original HDD disconnected I tried to perform an install on the SSD but received the error message "The selected disk has an MBR partition table.  On EFI systems, Windows can only be installed to GPT disks".  I'm surprised that I have not seen this on any other blog.  After 6 or 7 calls with Dell they told me to contact Crucial as they thought the problem was with the SSD.  I called Crucial support and they told me to change the disk to GPT in Disk Management.  I had also created a simple volume on the SSD earlier but was told to delete this.  He also told me to change the Boot mode to "Legacy Off".  You need to press F12 repeatedly (1 second apart) to get to this when turning on the computer.  After that I was able to install the Win OS onto the SSD.  The perseverance has finally paid off - just took way longer than I expected.

    It has been about 10 days since I installed the OS on the SSD and so far, no problems. 

    Jeremy