SSD install on XPS Studio 8000 ( no AHCI in BIOS )

Desktop

Desktop
Desktop computer Hardware and Software discussion

SSD install on XPS Studio 8000 ( no AHCI in BIOS )

This question is not answered
Want to pick up a ssd for my XPS 8000. Noticing that there is no AHCI in the bios. Is there a way around this? I was hearing that I can set the BIOS to RAID and that will force AHCI. Is there any info on this? Thank you and Merry Christmas.
All Replies
  • Hi Domchin,

    Your system supports the use of an SSD (at SATA II speeds), but does not support AHCI.

  • Thanks Os, so it would prob not be a good idea to use an SSD in this machine? Since there is no AHCI, no trim is supported on the drive correct?

  • That I'm not sure about. It depends on whether the current RST supports TRIM under RAID. Can't say that I know the answer.

  • Will the bios put the SSD in AHCI if i set it to RAID?

  • The Intel RST will report AHCI if your drive is running in AHCI. You can check that now.

  • Hello

    I have the same problem. I can't find AHCI in the BIOS

    I want to install my intel SSD 520, 120GB

    The Onchip SATA type only ATA of RAID (and not AHCI

    What is the best option? ATA of RAID?

    Ik have a Dell Studio XPS 8000, BIOS versie: A03, Chipset: Intel PCH P55

    Intel(R) Core(TM) i7 CPU 860 @ 2.80GHz (CPU:0)

    Have you already installed your SSD? and what is the best option for the SATA type in the BIOS?

  • Hi Boes1001,

    You definitely want RAID.

  • Hi Osprey4

    thanks for your reply

    i don't want RAID

    I just setup in my BIOS SATA on RAID, but I couldn't startup my PC!  ;-(.

    So I switched again to ATA, My PC runs now on my HDD and works.

    I think I will not change SATA (now it is switched to ATA), and set my SSD to the SATA1 port and install my windows 7 on it. I hope I can set TRIM on afterwards,

  • You have to run the Microsoft FIX to switch to AHCI.

    Go from IDE mode to AHCI mode for your SATA devices by running the Microsoft Fix It tool to enable AHCI driver support.

    After running the MS Fit It Tool, reboot, enter the BIOS, change your controller mode to RAID AHCI, save the BIOS settings and reboot back into Windows.

    Microsoft Fit It Tool – Enable Sata AHCI mode

    After you use the BIOS setup of a Windows 7-based computer or a Windows Vista-based computer to change the Serial Advanced Technology Attachment (SATA) mode of the boot drive to use either the Advanced Host Controller Interface (AHCI) specification or redundant array of independent disks (RAID) features, you receive the following error message when the computer is restarted: 

    STOP 0x0000007B INACCESSABLE_BOOT_DEVICE

    Report Unresolved Customer Service Issues here:

    Dell - Unresolved Customer Service Issues

    I do not work for Dell. I too am a user.

    The forum is primarily user to user, with Dell employees moderating.

  • First you have to backup all your drives or disconnect the ones that you don’t want formatted.

    After you select raid in the bios and reboot, immediately hit “control I” or the pause button.

    You will see some writing flash on the screen only for about 2 seconds. Hit the pause button and you can read it. Hit the pause button again and (control I) immediately will take you into the raid format utility. Or just sit control I use the writing flash on the screen. You have to do it quick so keep your fingers on the control and I keys waiting to press.

    Raid will reformat the drive and erase all data on all drives that are connected.
    It will ask you if you’re sure you want to erase all data. Then reinstall your operating system under raid.

    That’s how I did it. My XPS 8000 now works under raid with a Dell SSD 128 gig and it’s at least three times faster than the hard drive. Takes less than 20 seconds to bootup Windows 7.  

    It also got my DVD drive to work when it stopped working when I first installed the SSD.

  • Oops DragonDictate typos

    Or just sit control I use the writing flash on the screen.

    Should be

    Or just Hit “control I” when the writing flashs on the screen.

  • It will certainly make a huge improvement, but I wouldn't recommend using it with XP.

  • Hello,

    I am trying to get into the RAID configuration console using Control I.  When I only have my Samsung 840EVO SSD connected I cannot get into the menu.  When I connect my additional HDD and 840EVO SSD together I am able to get into the configuration utility.  How can I just set up RAID on my SSD drive only?

    Thanks

  • Hi Msuk,

    The Ctrl-i option only appears when there's more than one hard drive. You do not want to set up an actual RAID unless the two drives are the same size.

  • Hi, I have set the BIOS to RAID, installed Windows 8.1 but the Samsung SSD software is reporting AHCI is deactivated. Is it possible to activate AHCI? Thanks