Forums

Desktop

Desktop
Desktop computer Forums (Audio, General Hardware, Video)

Enabling 32GB SSD Cache on XPS 2720

This question is not answered

I just got a Dell XPS 2720 from the Outlet and it rocks so hard, except I can't get the SSD cache working and it's bugging me since I paid extra for it.

So far:

  • I received the computer and did a clean install of 8.1 with RAID mode set in the BIOS.
  • Installed all drivers and updates etc.
  • Opened Intel Rapid Storage to enable Smart Response but the Accelerate tab is missing. Performance only shows a power management option.

I tried using diskpart to clean the SSD, initializing it as MBR, GUID, setting up a RAW partition, etc and a ton of combinations of things in Disk Management but I cannot get IRST to give me that Accelerate option.

Anybody have any luck with this?

All Replies
  • I'm in the same boat.  Here are my steps if it helps:

    1.  Installed Windows 8 from Dell recovery DVD onto 2TB mechanical drive.

    2.  Upgraded 8 to 8.1, installed the very latest Intel RST v 12.

    3.  Did the bcdedit trick to enable safe mode.

    4.  Restarted computer, set BIOS to RAID from AHCI, got into safe mode to reverse the bcdedit and restarted

    5. Windows 8.1 now boots with RAID mode option enabled in BIOS, but Intel RST still does not give me the accelerate option.

  • Seems to me that Dell should have a recommendation for resolving this.

    I too received the refurb unit last week from the Woot deal.

    When setting it up, I noted that the mSATA SSD was assigned a drive letter, and I knew this was not right.

    Also note that my BIOS is still A01, not A05 which is the current release.

    The refurb unit came with no documentation other than the warranty booklets.

    The recovery disc was included. Was able to find all the documentation on the website.

    Also note that there is no Genuine Windows Key code, but does have a genuine Windows sticker hiding on the back. Do Windows 8 OEM installs no longer require any Key?

    Waiting for some official words from Dell before I attempt to change the BIOS settings to RAID and try to get RST mode working.

    Otherwise, I really do like this AIO.

  • Windows 8 keys are baked into the firmware now, so you don't need to enter one....however, if you do a clean install of Windows 8.1 (not 8) you will. I grabbed it with Produkey for activation.

    Mine is the latest BIOS so no difference there...

    I've got an open ticket with Dell Prosupport and I'll update if we figure it out...I think it's really more of Intel's fault than Dell's. It's weird.

    It might be worth just ebaying this msata for a 64-128GB and sticking the whole OS on there, but I don't want to reinstall or spend the money, haha.

    It really is an awesome system! I did have some funkiness with the touch screen not working and needing to reboot, but I updated the firmware for it and haven't had it happen since. I do notice some flicker on really white full screens on IE but I noticed that on a 27" iMac I was using the other day as well with a totally white screen.

    Otherwise it's so cool and I'm surprised how powerful the 750m is!

  • I have two systems with the raid/accelerate "bit" issue now.  My guess is that somehow between Dell's bios and Intel's drivers, the Intel driver is not getting that the raid "bit" is set.  They already took the first one back but the replacement had the same issue somehow...  Both were A01 Bios but I have other that work fine with both A05 and A01.

    They've got to fix this!  Soon let's hope.

  • Still no luck. Here is what I did this afternoon:

    - made System Recovery DVDs (two 4.7GB DVD+R discs)

    - made USB Recovery Stick

    - upgraded BIOS to A05; though instructions said to make DOS bootable USB Stick, I was successful running the updater from Windows 8

    Reinstalled Win8 from the USB Recovery Stick. Noted that a few programs missing from the original factory delivered Win8 were now installed -- ie Intel and Dell utilities, in addition to the DVD Player utilities that were previously present. Ran Dell diagnostics, no problems found.

    Downloaded and installed the RST update, installed. Still no opportunity to enable acceleration.

    Oh well...now to wait for all the other updates to finish installing.

  • Hi,

    I had the same problem too showing mSATA drive on my computer and had no option to enable the caching. Had a hour long chat with dell support  and they concluded that even if it doesn't show  on intel RST, they are pretty sure it was enabled. But i know it was wrong. And i did some research for hours and found that if the drive is formatted or has some data in the mSATA drive, the intel RST will not recognize the drive for caching.

    Before you make nay changes make sure that you don't have any data in that mSATA drive and RAID is set in the BIOS correctly. Goto computer management and then click disk management. here you find different drives in the system. mSATA drive volume should on the list. Delete the mSata drive volume from it. Don't format it just delete the volume. Now goto intel RST, now you have the option the configure the drive for caching. This process worked for me. Let me know  whether it  worked for you guys or not.


    -DJ

  • Taravind,

    Missed your latest comment until now, but I came to same conclusion.

    As delivered, my mSATA was formatted and partitioned, showing as a drive letter in Explorer as well as in RST.

    So this morning, after thinking a bit,

    - I opened an Administrator CMD window

    - went into DISKPART

    - selected the mSATA drive (be sure to select the right disk!)

    - issued CLEAN command to remove partition info

    - EXIT from DISKPART

    - EXIT from CMD

    - Restarted

    - fired up Intel RST

    - option to accelerate was enabled

    - configured the mSATA as cache and the HDD as the volume to accelerate

    - after about a minute, I got an error, and was advised to Restart

    - I did Restart

    - fired up RST again, and the statusscreen confirmed I now had an accelerated HDD

    All is well!

  • I tried all of that with no luck. :(

    According to Dell ProSupport, it's a firmware glitch with certain hard drives. They are sending a tech out to swap the HDD with another one...I kind of doubt it will fix it, but we'll see...

  • This indeed did work for me and should be listed as answered

    Thanks Taravind

  • I found the solution aforementioned to work on my particular XPS 2720. "Clearing the mSATA drive partition, installing the latest Intel Rapid Start software." I also found that Dell is correct about certain mSATA drives incompatible with Intel Rapid Start software. After a few tries I did get the 32Gb mSATA drive to cache as intended, however I was still not satisfied. I removed the 32Gb mSATA drive and replaced it with a Mushkin 240Gb mSATA drive, then loaded Windows 8.1 pro operating system on the new mSSD. My upgrade was rather expensive, and not a solution, but the outlet price with a $250 coupon discount allowed me to have a very responsive AIO XPS 2720 that impresses everyone that uses it in my shop. I just bought another Dell Outlet XPS 2720 and another Mushkin 240GB mSATA drive. I got the same discount on the XPS 2720 with a coupon, and the 240Gb mSSD Mushkin drive is only $119 at Newexx. There is no denying that booting from an SSD is by far superior to a cached mechanical drive. Ideally the XPS 2720 should have two SSD drives in raid 0. But that is another day.
  • Everybody seems to have a different story how to get the RST SSD cache back to work, so here's mine:

    After a disk crash I had to reinstall Windows 8 and update to Windows 8.1. For some reason I ended up with a recovery partition at the beginning and at the end of the disk. It seems that the RST Accelerate option does not show up if the last partition is not the OS.

    After I deleted the recovery partition with the diskpart utility (select disk, select partition, delete partition override) and extended the OS partition to the end of the disk, the acceleration tab showed up and Smart Response is working! So the error was not the mSATA SSD drive, but the partition structure on the OS disk.

    So I guess, if the OS partition is not the last partition on the disk, the Smart Response option will not show up. Intel really should document this better.