M17x AC Adapter not charging battery

Alienware Club

Alienware Club
Share your Alienware experiences and join in the conversation with other Alienware users.

M17x AC Adapter not charging battery

This question has been answered by emmjay15

I recently just got my M17x and for some reason when I plug in the AC adapter it often says plugged in not charging.  I have to unplug it then plug it in several times before it decides to begin charging again.  Sometimes Alienware OSD tells me it's not a supported AC adapter and it will continue running on battery power.  I did contact Alienware support and received a new Adapter, but the problem still exists.  Anyone else having this problem?

I'd try calling alienware support again, but for supossidly being open 24/7 they are always doing system maintenace around this hour.  I work nights so this is not convenient for me.

Verified Answer
  • Guys, took the laptop into a guy in the city (Melbourne).  We tried a few chargers, tried the Aleinware charger on some other Dells and concluded the charger was shot.  So, (fingers crossed) bought another online at Dell (the big 240w one) and voila, all good!  Now here's my take on what happened.  My daughter used to drape the charger lead from the floor up on the desk and the lead had a distinctive right angle bend about an inch or two from the end.  As reported elsewhere on the board, the charger lead tip has a centre wire that 'tells' the PC it's the right charger, etc, etc.  I figure this connection had broken and is why it still powered the machine but didn't charge the battery.  So, moral of the story.   Treat the charger and lead like a carton of eggs!

All Replies
  • What's frustrating is you posted this question over 2 weeks ago and you have not gotten any response... I just rec'd mine and am having the same problem...

  • What's frustrating is you posted this question over 2 weeks ago and you have not gotten any response... I just rec'd mine and am having the same problem...

  • I had the same issue before I did a power drain and that fixed it right away.  I removed the AC adapter first then removed the battery and held the power button down for 1 min fixed the issue right away.

  • This may be a stupid question, but... you did all this with the computer off, correct?

    Thanks for the help!



  • Yep can't get power into it if the battery and the AC adapter are unplugged Smile.

  • Sounds like a intermittend connection of the ID-signal (the 3rd lead in the cable) coming from the AC adapter.

    Inspect the DC jack or the DC plug center pin closely.

    Use the BIOS setup screen as diagnosis tool


    Extreme Laptop travel in the Middle-East and Asia

  • Well I have updated the BIOS and that will fix the problem but only temporarily... when the problem returns, reflash the BIOS and it is fixed again.... Function F2 makes no difference. The other tricks that have worked for other people, did not work for me...

    But I have found another temporary solution... better than reflashing the BIOS every time it happens... I reach under the notebook, slightly remove the battery (while plugged in) and push it right back in... the battery will instantly start charging again.

    I wish Dell would come up with a real solution.

    JB... South of the border

  • Thank you so much for that last post!  This solved my problem for me.  I was very worried, because I had managed to unplug my computer without realizing it and it wasn't until I was at 3% battery that I realized the problem.  Naturally, I had a huge essay due and a raid on WoW to attend and all sorts of computer-related commitments that couldn't be met if I was out of battery power.  But finally my battery is charging again.  I really should have thought to just take it out and put it back in!

  • Hi There!! I am a Dell Studio 1535 owner and I recently experienced an issue with my laptop concerning the AC Power adapter. When I would turn on the power adapter I would receive this message in the boot sequence.

    “The AC power adapter wattage and type cannot be determined. Your system will operate slower and the battery will not charge. Please connect a Dell 65W AC adapter or higher for best system operation”

    This problem had me a little perplexed. The system is a little over a year old and out of its warranty. I started doing some research on line and found that I am not the only one that is experiencing this problem!! Needless to say, there are some very angry customers out there.

    Well to solve this problem I initially ordered a new AC adapter. This adapter lasted about a month and the same problem occurred.

    So I decided to do some dissection of the adapter. I broke open the brick that held all the electronics and converters for AC to DC. I tested each connection and found no problem. Then I started to test the cord that plugged in to the laptop its self. I first tested the ground. This is the outer metal casing around the plug that fits in to the laptop. No problems there!! Then I tested the inside metal casing that is for the lead power. That one tested fine. I almost didn't notice it but there is a third line in these units. It is a very tiny pin located in the center inside the plug. I tested this line as well and low and behold I had found the problem. That little tiny wire in the middle had a break in it somewhere.

    After cutting apart the plastic around the plug head I found that that little wire must have gotten hot and burned its self up. The inside of the plug showed the markings of a short.

    The overall design of this cord is flawed. After looking at the wire connections I noticed that the pin in the center is just that a pin that the wire was soldered on to. There were no signs of a crimping mechanism, looping hole or anything that would give the wire stability against tugging or kinking. Needless to say that if the cord were accidently pulled out or bent at the connection area the tiny little wire in the center would break away and short out.

    You may ask what this tiny little wire is. Well it is simple, there is a little chip in the brick that sends a signal to the laptop telling it that the adapter connected is in fact a dell 65W or higher adapter and is allowed to charge the battery. If this wire gets broken then the adapter cannot send the signal and the laptop essentially thinks that there is an "UNKNOWN" adapter connected.

    These adapters are smart; they sense when the battery is fully charged and send a signal to the laptop to divert power away from charging the battery and towards running the laptop more efficiently. This method conserves battery life.

    So if you are having this problem I am sorry but there is little to do about it but order a new adapter and be careful not to tug, bend or kink the line. I however having no warranty and being knowledgeable about these types of electronics have fixed the problem by re-soldering the tiny wire back together. Although this is not very pleasing to the eye; due to the fact that you have to cut apart the casing and then cover it back up with electrical tape or some other means of guarding the wires. But over all I am pleased that I could fix the problem myself.

    On another note I did order a new AC power adapter from dell and plan on being more careful with this one in the future.


  • I've had the same issue right out of the box with my alienware laptop.  Having the latest (09) bios makes no difference, nor does the fn F2 key.  Why in the world would anyone design a laptop to not charge by default?  I, too, must resort to reseating the battery - an absolutely ridiculous solution.  How about a serious solution Dell/Alienware?

  • It's good news bad news. I think my Inspiron 1545 is experiencing the same issue. I have a message on the battery icon that says "plugged in not charging" so I bought a new battery. Same thing. So I sent it to Square Trade Warranty for repair. They sent it back and said it was the AC adapter. But sounds like if I buy another AC adapter, this could happen again. I am I reading that right? In that case, is there a better fix for this issue? Thanks for your very detailed explanation. That was very kind!

  • I have also been having this problem with my m17xr2. Talked to alienware and they sent a new charger and battery which did not fix the problem.

    I am a software programmer and spent a couple of hours looking into this problem.

    I believe i have found the solution for this problem. I called alienware tech support and spoke to a manager and they said they had found a solution and that was to flash the bios two or three times.

    Can anyone that is still having this problem please try this solution and let me know if it works?..Thanks Mike

    This did not work for me. Although, i did some more reserch and it appears this is a windows software problem. I found this solution and it appears to be working. I have shut down the computer and restarted several times and i can remove the ac adapter and plug it back in and it charges now. Hope this helps...Mike

    1. close laptop and remove battery (while still on). 

    2. open lid and remove AC adapter (while still on, will power off system)

    3. close lid and connect battery

    4.  open lid, connect AC adapter, and power on.


  • Same problem too. Thank you for the solution. Hopefully this works for me.
  • UPDATE: This procedure has solved the problem. Thank you!
  • Arrgh, help!  Have the same problem, says power connected, battery not charging.  When the plug is pulled and re-inserted then pops up with a message from the graphics card saying its a non-supported charger.  Ive been wanting to flash the BIOS but the battery is down to 3% (needs to be 10%) and have already wasted money on a stand alone battery charger (incompatible plug).  This is my daughters laptop, 18 months old and she's so apologetic because she thinks she's busted it.  Not good enough Dell, for a $3000+ machine, I now have to take a punt on buying a battery (which I think is fine), buying an another power adapter (which I don't know), trying to get enough battery charge somehow (go into a shop and borrow an Mx17 to put my battery in!) so I can flash the BIOS (which I don't think will fix it) or then maybe the charging mechanics of the machine are stuffed.  Ive tried a few of the suggestions here and from other searches, any other suggestions greatly appreciated!